技术论坛

打开程序出现的问题

作者 主题
侠客

经验值: 871
发帖数: 336
精华帖: 1
打开程序出现的问题


只看楼主 2006-09-11 12:30:28
请教:我在打开程序时,出现一个错误提示:The project"xx"contains errors in the internal data structure.然后电机确定,还可以再进行编程啊,好像下载程序也没什么事,不知实际运行是怎样?这是什么怎么造成的呢?有什么错误?
 
以下网友喜欢您的帖子:

  
重要声明:

著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

帖子链接:http://www.ad.siemens.com.cn/club/bbs/post.aspx?a_id=271587&b_id=4&s_id=0&num=10

游侠

经验值: 347
发帖数: 274
精华帖: 0
回复:打开程序出现的问题


只看楼主 2006-09-11 16:39:23
查查你编写的程序什么地方出限“红色”;看这说明应该是数据结构有问题,看看DB块
I believe i can
以下网友喜欢您的帖子:

  
版主

经验值: 55001
发帖数: 16431
精华帖: 315
回复:打开程序出现的问题


只看楼主 2006-09-11 16:51:42
乘早新建一个项目,把能拷贝的都拷贝出来
Zane 注册自动化系统工程师 Always save before download
以下网友喜欢您的帖子:

  
侠客

经验值: 871
发帖数: 336
精华帖: 1
回复:打开程序出现的问题


只看楼主 2006-09-12 10:07:57
因为我要和触摸屏连接通讯,所以按触摸屏的要求我建了一个DB10,但是空的,一般情况下只建一个空的数据块可以吗?我连接的是eview触摸屏
 
以下网友喜欢您的帖子:

  
侠士

经验值: 1399
发帖数: 849
精华帖: 5
回复:打开程序出现的问题


只看楼主 2006-09-12 14:01:17
空的当然不行!需要针对触摸屏需要添加变量!
好好生活,天天向上!
以下网友喜欢您的帖子:

  
奇侠

经验值: 9801
发帖数: 4325
精华帖: 26
回复:打开程序出现的问题


只看楼主 2006-09-12 15:37:38
eview触摸屏与S7300,当变量为字节或字、双字(例如PIW256,MW100等)时不能直接引用PLC的地址(例如一引用PIW256,当编译下载时就报错),需转存到一数据块中(DB10....DB20),再引用DB块的地址。
即,eview触摸屏与S7300,当变量为字节或字、双字时,只认DB块的地址。
故DB10针对触摸屏需要添加所需的数据。
这是本人个人的体会,不知真是如此。
一日三省吾身
以下网友喜欢您的帖子:

  
游侠

经验值: 347
发帖数: 274
精华帖: 0
回复:打开程序出现的问题


只看楼主 2006-09-13 11:17:55
看来还是你的DB块的问题
I believe i can
以下网友喜欢您的帖子:

  
侠客

经验值: 871
发帖数: 336
精华帖: 1
回复:打开程序出现的问题


只看楼主 2006-09-13 15:35:22
谢谢了,过几天就要调试了,我再改改程序,有什么情况再请教!感谢大家支持!
 
以下网友喜欢您的帖子:

  
游士

经验值: 216
发帖数: 119
精华帖: 0
回复:打开程序出现的问题


只看楼主 2006-09-13 17:20:01
internal data error的话,去File-- Reorgnize一下,要么右键blocks--check block consistency试试看,根据check的结果修改
 
以下网友喜欢您的帖子:

  
游士

经验值: 184
发帖数: 139
精华帖: 0
回复:打开程序出现的问题


只看楼主 2006-09-14 09:16:00
楼上说的对,而且很有可能就是数据块有问题
西门子PLC爱好者[url]http://smzplc.2008red.com[/url]
以下网友喜欢您的帖子:

  
游士

经验值: 217
发帖数: 63
精华帖: 2
回复:打开程序出现的问题


只看楼主 2006-09-18 11:59:13
XINKE 说的对,不过我建议楼主随时备份程序,那要省多少事啊。
 
以下网友喜欢您的帖子:

  
  • 上一页
  • 1
  • 下一页
收起
打开程序出现的问题
×
扫描打开手机版
您收到0封站内信:
×
×
信息提示
很抱歉!您所访问的页面不存在,或网址发生了变化,请稍后再试。