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法律资讯 
警告提示系统 

为了您的人身安全以及避免财产损失，必须注意本手册中的提示。人身安全的提示用一个警告三角表示，仅与财产

损失有关的提示不带警告三角。警告提示根据危险等级由高到低如下表示。 

危险  
表示如果不采取相应的小心措施，将会导致死亡或者严重的人身伤害。 

警告  
表示如果不采取相应的小心措施，可能导致死亡或者严重的人身伤害。 

小心  
带有警告三角，表示如果不采取相应的小心措施，可能导致轻微的人身伤害。 

小心  
不带警告三角，表示如果不采取相应的小心措施，可能导致财产损失。 

注意  
表示如果不注意相应的提示，可能会出现不希望的结果或状态。 

当出现多个危险等级的情况下，每次总是使用最高等级的警告提示。如果在某个警告提示中带有警告可能导致人身

伤害的警告三角，则可能在该警告提示中另外还附带有可能导致财产损失的警告。 

合格的专业人员 
本文件所属的产品/系统只允许由符合各项工作要求的合格人员进行操作。其操作必须遵照各自附带的文件说明，特

别是其中的安全及警告提示。 由于具备相关培训及经验，合格人员可以察觉本产品/系统的风险，并避免可能的危

险。 

Siemens 产品 
请注意下列说明： 

警告  
Siemens 产品只允许用于目录和相关技术文件中规定的使用情况。如果要使用其他公司的产品和组件，必须得到 
Siemens 推荐和允许。正确的运输、储存、组装、装配、安装、调试、操作和维护是产品安全、正常运行的前

提。必须保证允许的环境条件。必须注意相关文件中的提示。 

商标 
所有带有标记符号 ® 的都是西门子股份有限公司的注册商标。标签中的其他符号可能是一些其他商标，这是出于保

护所有者权利的 目地由第三方使用而特别标示的。 

责任免除 
我们已对印刷品中所述内容与硬件和软件的一致性作过检查。然而不排除存在偏差的可能性，因此我们不保证印刷

品中所述内容与硬件和软件完全一致。印刷品中的数据都按规定经过检测，必要的修正值包含在下一版本中。 

 

 Siemens AG 
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90026 NÜRNBERG 
德国 
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Copyright © Siemens AG 
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简介 1
 

本文档的用途  

使用本文档中的信息，您可以仿真 S7 可编程逻辑控制器的操作。 您可以测试控制程序，

无需连接 S7 硬件。 

读者对象 

本文档面向那些具有 S7 可编程控制器和 STEP 7 编程知识与经验的开发人员、程序员以

及维修人员。 

所需背景知识 

为了理解本文档的内容，您需要掌握一些自动化工程方面的常识。 还需要具备以下基本

知识： 

● STEP 7 基本软件，尤其是： 

– 使用 SIMATIC Manager 

– 使用 HW Config 进行硬件配置 

文档的有效性 

本手册适用于 V5.4 SP 5 或更高版本的 S7-PLCSIM 仿真软件。 

自上一版本的更改 

S7-PLCSIM 现具有以下新属性： 

● 优化下载方案 

● 支持额外的 PG/PC 接口： PCinternal（本地） 

● 简化访问方式 

● 优化 WinCC 与 WinCC flexible 之间的通信 

● 在状态栏中显示所有 CPU 访问地址 
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文档类别 

此文档描述 S7-PLCSIM 的功能和操作。  

有关详细信息，请参考 STEP 7 在线帮助和以下手册：  

 

标题 内容 

入门指南 

 STEP 7 入门指南和练习 本手册讲解如何使用 STEP 7 自动化软件。 此手册

提供用于组态 PLC 和开发控制程序的过程概述。 

参考手册 

 用于 S7-300/400 系统和标准函数的系统软件 此手册描述您在开发控制程序时需要使用的系统函

数、组织块以及标准函数。 

手册 

 使用 STEP 7 进行编程 此手册提供有关设计和编程控制程序的基本信息。 
在使用 STEP 7 自动化软件创建控制程序时，请使

用本手册。 

可通过以下方法查找本手册以及其他手册：在安装 STEP 7 的计算机的 Windows“开始”菜
单中选择菜单命令“开始 > SIMATIC > 文档”(Start > SIMATIC > Documentation)。  

指南 

本文档描述 S7-PLCSIM 仿真软件的操作方法。 它包括说明部分和参考部分。 本文档包

括以下主题区： 

● 产品概述 

● 入门指南 

● 仿真任务 

● 视图对象的定义 

● 错误和中断 OB 的定义 

● 参考信息，如故障排除技巧 
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Internet 上的服务与支持 

可在 Internet (http://www.automation.siemens.com/simatic/portal/html_76/techdoku.htm) 
上找到各种 SIMATIC 产品和系统的技术文档向导。 

在 Internet (http://www.siemens.com/automation/service&support) 上，除了文档库之

外，我们还将提供一个完整的在线知识库。 在此处您将找到以下信息： 

● 新闻快递，提供有关您的产品的最新信息。 

● 在“服务与支持”页面上您所购买产品对应的文档。 

● 全球的用户和专家可用来交流知识的电子公告牌。 

● 可在我们的联系方式数据库中找到当地自动化与驱动部门的联系方式。 

● 有关现场服务、维修、备件以及更多方面的信息。 

http://www.automation.siemens.com/simatic/portal/html_76/techdoku.htm�
http://www.siemens.com/automation/service&support�
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产品总览 2
2.1 功能范围 

简介 
在 S7-PLCSIM 中，您可以在仿真可编程逻辑控制器 (PLC) 中执行以及测试您的 STEP 7 
用户程序。 仿真在您的 PC 或编程设备（如 Field PG）中执行。 由于仿真是完全在 
STEP 7 软件中实施的，因此您不需要任何 S7 硬件（CPU 或信号模块）。 您可以使用 
S7-PLCSIM 仿真专为 S7-300、S7-400 以及 WinAC 控制器开发的 STEP 7 用户程序。  
S7-PLCSIM 提供一个简单的 STEP 7 用户程序界面，以供监视以及修改诸如输入和输出

变量这样的不同对象。 当在仿真 CPU 上运行您的程序的同时，您还可以使用 STEP 7 软
件的各个应用程序。 例如，这允许您使用诸如变量表 (VAT) 这样的工具来控制和监视变

量。 S7-PLCSIM 提供一个用于查看和修改控制程序变量、在单次或持续扫描模式中运行

仿真 PLC 程序、更改仿真控制器的工作模式的图形用户界面。 
此外，S7-PLCSIM 还包含名为 S7ProSim 的 COM 对象，此对象提供对仿真 PLC 的编程

访问。 通过 S7ProSim，您可以编写软件以执行诸如更改仿真 PLC 的钥匙开关位置、在

单次扫描模式中运行控制程序以及读取或写入控制器值这样的任务和许多其它任务。 
Internet 上提供有关 S7ProSim 
(http://support.automation.siemens.com/WW/view/en/1139855/0/en) 的文档。 

功能 

S7-PLCSIM 具有如下范围的功能： 
● 启动时 打开现有仿真 (页 36) 
● 在仿真 PLC 上运行专为 S7-300、S7-400、T-CPU (页 57) 以及 WinAC PLC 设计的

程序 
● 创建 视图对象 (页 59)，这可以使您访问仿真 PLC 的输入和输出存储区、累加器以及

寄存器。 
● 通过 符号寻址 (页 49)访问存储器。 
● 自动运行定时器 
● 手动置位定时器，或着复位所有定时器或一个 定时器 (页 48) 
● 切换 CPU 工作模式 (页 60)（STOP、RUN 以及 RUN-P） 
● 使用“暂停”(Pause) 菜单命令暂停仿真，而不影响程序的状态 
● 使用 错误和中断 OB (页 69) 测试程序的运行情况 
● 记录 (页 50)一系列事件（修改输入和输出存储区、位存储器、定时器以及计数器） 
● 回放程序记录，以便自动测试 

http://support.automation.siemens.com/WW/view/en/1139855/0/en�
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在 STEP 7 中集成 

您可以对仿真 PLC 使用所有 STEP 7 工具。 尽管仿真 PLC 完全存在于软件中，但 
STEP 7 会将仿真 PLC 作为真正的 S7 PLC 来使用，几乎不存在任何 区别 (页 12)。 

2.2 与“真正”PLC 的区别 

仿真 PLC 的功能  

仿真 PLC 提供以下“真正”PLC 所不具备的功能： 

● “暂停”命令 (页 44)暂停仿真 CPU，并允许您从程序暂停的指令处继续执行程序。 

● 如果在 STOP 模式中使用仿真 CPU，则 S7-PLCSIM 不会更改输出状态。 如果选择 
RUN 模式选择器 (页 60)位置，则您将无法下载 STEP 7 用户程序或使用 STEP 7 工
具更改任何参数。 真正 S7 PLC 允许在设置 RUN 模式选择器时下载程序以及更改参

数。 

● S7-PLCSIM 支持四个累加器（类似于 S7-400 CPU）。 在某些特殊情况下，同一程

序在 S7-PLCSIM（带有四个累加器）中的运行方式可与 S7-300 CPU（仅带有两个累

加器）中的运行方式不相同。 

● 您对视图对象所作的任何更改会立即更新存储单元中的内容。 仿真 CPU 不会等到扫

描开始或结束才更新所有已更改数据。 

● 扫描模式选项允许您选择 CPU 运行程序的方式： 

– 单次扫描 (页 39) 

– 持续扫描 (页 39) 

● 可自动处理定时器，或手动输入值。 您还可以全部或单个 复位 (页 48)定时器。 
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● 您可以手动触发错误和中断 OB： 

– OB40 至 OB47 (页 71)（硬件中断） 

– OB70 (页 72)（I/O 冗余错误） 

– OB72 (页 73)（CPU 冗余错误） 

– OB73 (页 75)（通信冗余错误） 

– OB80 (页 75)（时间错误） 

– OB82 (页 76)（诊断中断） 

– OB83 (页 78)（插入/卸下中断） 

– OB85 (页 79)（程序顺序错误） 

– OB86 (页 80)（机架故障）。 

● 过程映像和外设存储器： 如果更改过程输入映像中的值，则 S7-PLCSIM 会立即将此

值复制到该输入的 I/O 区。 这样的话，如果在下一扫描开始时将 I/O 区输入值写入过

程输入映像中，将不会丢失所需更改。 相应地，如果您更改了 I/O 区输出值，则会立

即将此值复制到过程输出映像中。 下图说明扫描周期中的活动顺序： 

 

在仿真 CPU 中，当从 STEP 7 变量表中修改变量时，您必须确保过程映像更新未重写或

覆盖您的预期修改内容。 按照以下步骤为修改变量设置触发点： 

● 对于输入，请选择“扫描周期开始”(Beginning of scan cycle) 作为“修改的触发

点”(Trigger Point for Modifying)。 

● 对于输出，请选择“扫描周期结束”作为“修改的触发点”(Trigger Point for Modifying)。 
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更多区别 

仿真 PLC 不提供以下“真正”PLC 所具备的功能： 

● 诊断缓冲区： S7-PLCSIM 不支持写入诊断缓冲区的所有错误消息。 例如，在 CPU 
或 EPROM 错误中无法仿真与故障电池相关的消息。 但大多数的 I/O 和程序错误都可

以进行仿真。 

● 工作模式 (页 60)的切换不会将 I/O 更改为“安全”状态。 

● 不支持函数模块 (FM)。 

● 不支持点对点通信（如同一机架上的两个 S7-400 CPU 之间的通信）。 

● S7-PLCSIM 不支持强制变量。 

● S7-PLCSIM 执行某些 SFB (页 18) 和 SFC (页 19) 的方式与真正 S7 PLC 的方式相

同；至于其他方面，S7-PLCSIM 验证输入参数并返回有效输出，而带有物理 I/O 的真

正 S7 PLC 所返回的输出不一定是有效输出；S7-PLCSIM 将多余部分视为 NOP。 

● 无论要仿真哪种型号的 CPU，S7-PLCSIM 的本地数据的大小均定义为每个优先级 32 
kB。 由于实际硬件中的本地数据组态可能与 S7-PLCSIM 中的不同，因此可能会出现

下载到该硬件时被拒绝的情况。 

● S7-PLCSIM 不支持多值计算： S7-PLCSIM 无法使用多个 CPU 仿真 SIMATIC 站
（多值计算）。 

● S7-PLCSIM 不支持 H 系统。 

● PLCSIM 不支持 PROFINET I/O 

I/O 的区别 

S7-300 系列的大多数 CPU 均自动组态 I/O： 将模块插入物理控制器后，CPU 会自动识

别此模块。 仿真 PLC 无法仿真自动组态功能。 如果将程序从自动组态 I/O 的 S7-300 
CPU 下载到 S7-PLCSIM 上，则系统数据中不包含 I/O 组态。 因此，首先您必须将带有

已组态 I/O 模块的硬件配置下载到系统数据中，以便定义 CPU 应使哪个模块可用。 

要执行此操作，请创建一个项目，然后组态 S7-300 CPU（其中未自动组态 I/O），例如 
CPU 315-2DP、CPU 316-2DP 或 CPU 318-2。将此硬件配置下载到 S7-PLCSIM 中。 
然后您可以下载任意 S7 项目中的程序块。 应用这些 I/O 时不会出现错误。 
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2.3 仿真查看窗口 

用户界面 

S7-PLCSIM 的仿真查看窗口包含工作区、标题栏、状态栏以及 S7-PLCSIM 菜单和工具

栏 (页 83)。 S7-PLCSIM 布局即为您显示 视图对象 (页 59)的位置。 

 
1 标题栏 
2 菜单栏 
3 工具栏 
4 工作区 
5 视图对象 
6 状态栏命令 
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2.4 存储区 

具有不同功能的存储区                 

您可以通过寻址存储器的特定区域来访问 S7 PLC 中的数据，这会执行特定功能： 

 

存储区 说明 寻址 S7-PLCSIM 范围 

定时器 存储定时器 T T 0 至 T 2047 

计数器 存储计数器 C C 0 至 C 2047 

位存储器 存储在 STEP 7 用户程序中使用

的数据 
M M 存储器为 131,072 位（16 

KB） 

可寻址的 I/O 直接访问输入和输出模块 

注： CPU 在各 CPU 扫描周期结

束时更新外设输出。 

PI： 外设输入 
PQ： 外设输出 

I/O 存储器为 262,136 位
（32 KB） 

过程映像（可组

态；每隔一次扫

描更新一次） 

输入和输出的过程映像存储 

注： CPU 在各 CPU 扫描周期开

始时更新输入 

I： 输入 

Q： 输出 

最大值： 131,072 位（16 
KB） 

默认设置： 131,072 位（16 
KB） 

本地数据（可组

态） 
供逻辑块（包括临时变量）使用

的存储器 
-/- 最大值： 32 KB 

默认设置： 32 KB 

数据块 数据块存储器 DB： 数据块 最大数量 > 65534 

最大长度： 65570 
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2.5 块 

2.5.1 组织块 (OB) 

支持的 OB 

S7-PLCSIM 支持以下列出的 OB： 

 

OB 说明 

OB1 自由周期 

OB10 到 OB17 日时钟中断 

OB20 到 OB23 延迟中断 

OB30 到 OB38 周期性中断 

OB40 到 OB47 硬件中断 

OB55* 状态中断 

OB56* 更新中断 

OB57* 特定供应商的中断 

OB60* 多处理器中断 

OB61* 到 OB64* 同步循环中断 

OB65* 工艺同步中断 

OB70 I/O 冗余错误 

OB72 CPU 冗余错误 

OB73 通信错误 

OB80 超时错误 

OB81* 电源错误 

OB82 诊断中断 

OB83 插入/卸下模块中断 

OB84* CPU 硬件故障 

OB85 优先级错误 

OB86 机架故障 

OB87* 通信错误 
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OB 说明 

OB88* 处理中断 

OB90* 背景 OB 

OB100 暖启动 

OB101 热启动 

OB102 冷启动 

OB 121 编程错误 

OB122 I/O 访问错误 

* 无法调用标有星号 (*) 的 OB。 

2.5.2 系统功能块 (SFB, System function block) 

支持的 SFB 

S7-PLCSIM 支持以下列出的 SFB： 

 

SFB 编号 简称 SFB 编号 简称 

SFB0 CTU SFB20 STOP 

SFB1 CTD SFB22 STATUS 

SFB2 CTUD SFB23 USTATUS 

SFB3 TP SFB31 NOTIFY_8P 

SFB4 TON SFB32 DRUM 

SFB5 TOF SFB33 ALARM 

SFB8 USEND SFB34 ALARM_8 

SFB9 URCV SFB35 ALARM_8P 

SFB12 BSEND SFB36 NOTIFY 

SFB13 BRCV SFB37 AR_SEND 

SFB14 GET SFB52 RDREC 

SFB15 PUT SFB53 WRREC 

SFB19 START SFB54 RALRM 
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2.5.3 系统功能 (SFC, System function) 

支持的 SFC 

S7-PLCSIM 支持以下列出的 SFC： 

 

SFC 编号 简称 SFC 编号 简称 SFC 编号 简称 

SFC0 SET_CLK SFC27 UPDAT_PO SFC54 RD_DPARM 

SFC1 READ_CLK SFC28 SET_TINT SFC55 WR_PARM 

SFC2 SET_RTM SFC29 CAN_TINT SFC56 WR_DPARM 

SFC3 CTRL_RTM SFC30 ACT_TINT SFC57 PARM_MOD 

SFC4 READ_RTM SFC31 QRY_TINT SFC58 WR_REC 

SFC5 GADR_LGC SFC32 SRT_DINT SFC59 RD_REC 

SFC6 RD_SINFO SFC33 CAN_DINT SFC62 CONTROL 

SFC9 EN_MSG SFC34 QRY_DINT SFC64 TIME_TCK 

SFC10 DIS_MSG SFC36 MSK_FLT SFC78 OB_RT 

SFC11 DPSYC_FR SFC37 DMSK_FLT SFC79 SET 

SFC12 D_ACT_DP SFC38 READ_ERR SFC80 RSET 

SFC13 DPNRM_DG SFC39 DIS_IRT SFC82 CREA_DBL 

SFC14 DPRD_DAT SFC40 EN_IRT SFC83 READ_DBL 

SFC15 DPWR_DAT SFC41 DIS_AIRT SFC84 WRIT_DBL 

SFC17 ALARM_SQ SFC42 EN_AIRT SFC85 CREA_DB 

SFC18 ALARM_S SFC43 RE_TRIGR SFC87 C_DIAG 

SFC19 ALARM_SC SFC44 REPL_VAL SFC90 H_CTRL 

SFC20 BLKMOV SFC46 STP SFC105 READ_SI 

SFC21 FILL SFC47 WAIT SFC106 DEL_SI 

SFC22 CREAT_DB SFC49 LGC_GADR SFC107 ALARM_DQ 

SFC23 DEL_DB SFC50 RD_LGADR SFC108 ALARM_D 

SFC24 TEST_DB SFC51 RDSYSST   

SFC26 UPDAT_PI SFC52 WR_USMSG   
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入门指南 3
3.1 启动仿真 

要求 

● 未打开其他任何仿真 PLC 

● 与真实 PLC 间不存在任何连接 

简介 

以下过程帮助您快速入门。 可从 SIMATIC Manager 中调用该仿真。 

步骤  

要启动仿真，请进行如下操作： 

1. 您可以使用以下方法之一启动 S7-PLCSIM： 

– 打开 SIMATIC Manager，然后单击  图标，或选择菜单命令“选项 > 仿真模

块”(Options > Simulate Modules)。 

将打开 S7-PLCSIM。 用户界面语言和助记键设置与 STEP 7 设置相同。 

– 从 Windows“开始”菜单中，选择菜单命令“SIMATIC > STEP 7 > S7-PLCSIM 仿真

模块”(SIMATIC > STEP 7 > S7-PLCSIM Simulating Modules)。 

将打开 S7-PLCSIM。 用户界面语言与 STEP 7 设置不相同。 如果您是第一次启动 
S7/PLCSIM，则界面语言为英语。 在后续启动中，S7-PLCSIM 将使用上次使用的

语言打开。 该设置是用户特定的设置。 
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结果 

仿真已启动。 视图对象 "CPU" 已打开。 

此 PLC 必须处于初始状态。 它具有以下属性和标准设置： 

● 支持任何连接 

● 支持任何地址 

● 标准地址 

● 以上次使用的界面为基础组态界面 

● 可立即下载 

使用仿真 PLC 可自动建立任意新连接。 您下载的所有程序均会转入仿真 PLC。 如果单

击 SIMATIC Manager 上的“可访问节点”(Accessible Nodes) 按钮，则将显示仿真 PLC 的
节点地址。 

 

 说明 
S7-PLCSIM 会自动将“S7ONLINE 访问点”更改为仿真子网。 在仿真期间，请勿通过“设置

PG/PC 接口”将此访问点更改为 S7-PLCSIM 未知的访问点。 在您结束仿真时，S7-
PLCSIM 会将访问点更改回初始设置。 
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3.2 设置 PG/PC 接口 

连接类型 

在 S7-PLCSIM 的先前版本中，您仅能通过 MPI 连接仿真 PLC。 在 S7-PLCSIM 中，您

可以通过以下任一接口组态类型进行连接： 

● PLCSIM (ISO) 

● PLCSIM（本地） 

● PLCSIM (MPI) 

● PLCSIM (PROFIBUS) 

● PLCSIM (TCP/IP) 

● ... 

 

接口组态 连接类型 

PLCSIM (ISO) 通过 MAC 地址 

PLCSIM（本地） 通过虚拟底板总线/软总线 

PLCSIM (MPI) 通过 MPI 接口 

PLCSIM (PROFIBUS) 通过 PROFIBUS 接口 

PLCSIM (TCP/IP) 通过 IP 地址 

... 未知连接类别 
 

 

 说明 
在 S7-PLCSIM 中，使用 MPI 接口的连接属于仿真 PLC 的默认设置。 随后，仿真 PLC 
将从上次使用的连接类别开始。 
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步骤 

要设置 PG/PC 接口，请进行如下操作： 

1. 在 STEP 7 中组态您的硬件配置。 

2. 启动 S7-PLCSIM。 

3. 在“标准”(Standard) 工具栏的下拉列表中，为虚拟 PLC 选择其中某个已组态的连接类

别。 

 

结果 

创建 PG/PC 接口。 
 

 说明 
在 SIMATIC Manager 中，在“标准”(Standard) 工具栏的下拉列表中所作的更改将影响菜

单命令“工具 > 设置 PG/PC 接口”(Tools > Setting the PG/PC interface) 的功能。 反过来

也是如此。 
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下拉条目中的颜色含义 

● 黑色黑色（示例： ) 

此颜色表示 CPU 支持此 PG/PC 接口。 可通过此接口完全访问 CPU。 

● 灰色灰色（示例： ) 

此颜色表示 CPU 不支持此 PG/PC 接口。 无法通过此接口访问 CPU。 可选择此接

口。 但不能访问 CPU。 

● 黑色-灰色（示例：  

使用多个有相同地址的 CPU 时会显示此颜色。 它表示虽然 CPU 支持 PG/PG 接口，

但目前无法通过此接口进行访问。 

3.3 S7-PLCSIM 的多重背景 

概述 

通过使用此新功能，可以同时仿真多个 CPU。  
 

 说明 
运行大量 Windows 程序时，如果无法启动任何其它程序或无法打开任何其它窗口，则对

于 S7-PLCSIM 的多实例模式，可能需要调整“Desktopheap 内存”操作系统群。 
有关该操作系统行为的详细信息，请参见 Microsoft 的帮助和 Internet 支持页面，文章 
ID： KB126962。 

 

要求 

● 至少打开了一个 S7-PLCSIM 实例。 

● STEP 7 中组态网络地址与 S7-PLCSIM 中的网络地址一致，或 PLC 处于初始状态 

步骤 - 仿真 

要同时仿真多个 CPU，请按照下列步骤操作： 

1. 打开一个新实例。 

2. 选择菜单命令“仿真 > 新 PLC”(Simulation > New PLC)。 

新的仿真实例将以初始状态启动。 将打开“CPU”视图对象。 
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使用多重背景时的具体下载方法 

所有默认 CPU 都具有相同的默认地址，下载过程中不会考虑此问题。 如果一个默认 
CPU 打开了多重背景，则会将 STEP 7 项目下载到标题栏中编号最低的实例中（例如：

S7-PLCSIM2）。 这就是实例编号。 

使用多重背景时的存储器行为 

如果打开了多重背景，则用户必须分别保存 

● 每个实例的每个工作区 

● 每个实例的每次仿真 

才能对这些实例进行归档。 

关闭多重背景 

如果打开了多重背景，关闭这些实例时，必须注意以下事项： 

● 要关闭所有实例，请单击 SIMATIC Manager 中的  

● 要分别关闭各实例，请选择菜单命令“仿真 > 关闭”(Simulation > Close)。 

3.3.1 选择连接类型 

下拉列表中条目的颜色含义 

要更改 S7-PLCSIM 中的 PG/PG 接口，请使用“标准”(Standard) 工具栏中的下拉列表。 
根据仿真 CPU 的数量以及是否可以通过设定接口进行访问，下拉列表中的条目可能具有

不同的颜色。 只有同时仿真多个 CPU 时，才会显示下列颜色：  

黑色-灰色（示例： ) 

使用多个有相同地址的 CPU 时会显示此颜色。 它表示虽然 CPU“1”支持 PG/PG 接口，

但目前无法通过此接口进行访问。 这是因为已选择 CPU“2”使用同一地址进行通信。 要
选择 CPU“1”进行通信，则需要再次选择该 PG/PC 接口。 随后，CPU“1”的颜色会变为

“黑色-黑色”。 CPU“2”的颜色会变为“黑色-灰色”。 
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3.3.2 支持的通信块 

S7-PLCSIM V5.4 的多实例启动功能支持在 CPU 间进行通信 

通过使用此新功能，可以同时仿真多个 CPU。 如果预先装载了相应的硬件配置，则不同

的 CPU 可以相互进行通信。 这要求涉及的 CPU 在同一子网中具有不同的地址。  

CPU 之间的通信支持下列通信块： 

● SFB8“USEND” 

● SFB9“URCV” 

● SFB12“BSEND” 

● SFB13“BRCV” 

● SFB15“PUT” 

● SFB14“GET” 

● SFB19“START” 

● SFB 20“STOP” 

● SFB 22“STATUS” 

● SFB 23“USTATUS” 

  说明 
S7-PLCSIM 不具有实时功能。 通信过程中可能会存在时间响应限制。 

3.4 下载 STEP 7 项目 

要求 

● 仿真已从 STEP 7 SIMATIC Manager 中启动 

● 已组态恰当的连接类型 

● STEP 7 中的地址与 S7-PLCSIM 中的地址对应，或 PLC 处于初始状态 
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步骤 

要下载 STEP 7 项目，请按以下步骤操作： 

1. 导航至 SIMATIC Manager 中的站。 

2. 单击 ，或选择菜单命令“PLC > 下载”(PLC > Download)。 

结果 

块和硬件配置被下载至仿真 PLC 中。 仿真系统采用已加载 CPU 的标识和所有已组态连

接数据。 

状态栏提供已在硬件配置中组态的网络地址总览。 

仿真系统使用“MRES”功能复位至系统的初始状态。 
 

 说明 
独立组态的 CP 
无法仿真独立组态的 CP。 
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3.5 仿真和监视 

步骤 

要仿真应用程序以及监视和控制应用程序，请进行如下操作：  

1. 打开 SIMATIC Manager 

2. 打开 STEP 7 示例项目“ZEn01_09_STEP7__Zebra”。 

3. 单击  符号以应用 S7-PLCSIM。 

4. 下载 (页 27)此示例项目。 

5. 在 S7-PLCSIM 中创建其他 “视图对象” (页 59)。 

可对仿真 PLC 中的数据进行监视。 

– 单击 ，或选择菜单命令“插入 > 输入变量”(Insert > Input Variable)。 此视图对象

显示 IB0（输入字节 0）。 将数据格式设置为“位”。 

– 单击 ，或选择菜单命令“插入 > 输出变量”(Insert > Output Variable) 以插入第二

个视图对象 QB0（输出字节 0）。 

– 单击 ，或选择菜单命令“插入 > 定时器”(Insert > Timer) 三次以插入三个“定时器”
视图对象。 在对应文本框中输入 2、3 和 4（针对定时器 T2、T3 和 T4），每次输

入后按 Enter 键。 （S7-PLCSIM 将为这三个定时器中的每个定时器填写符号名

称。） 

6. 选择菜单命令“PLC > 接通电源”(PLC > Power On) 

7. 选择菜单命令“执行 > 扫描模式 > 持续扫描”(Execute > Scan Mode > Continuous 
Scan) 

8. 选择菜单命令“执行 > 钥匙开关位置 > RUN”(Execute > Key Switch Position > RUN) 
或 RUN-P。 

仿真 CPU 处于 RUN 模式。 

9. 单击 IB0 的位 0，以仿真打开输入 0.0 以及 

10. 监视对定时器的影响。 

11. 单击 ，或选择菜单命令“文件 > PLC 另存为”(File > Save PLC As) 以将当前状态的

仿真 PLC 另存为一个新文件 (页 35)。 
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3.6 在 STEP 7 中监视程序仿真 

要求 

● 视图对象 (页 59)已创建 

● 示例项目“Zebra”已打开，同时已将站下载至 S7-PLCSIM 中 

步骤 

要在 STEP 7 中对您的程序仿真进行监视，请按以下步骤操作： 

1. 单击 ，或选择菜单命令“视图 > 联机”(View > Online)。 

“联机”模式将被激活。 

2. 浏览至 ZEBRA 示例项目中的“块”(Blocks) 对象。 

3. 打开函数 FC1。 

将调用“LAD/STL/FBD”应用程序。 

4. 将仿真 CPU 设置为 RUN 模式。 

5. 打开 IB0 的位 0。 

6. 选择“LAD/STL/FBD 编辑器”(LAD/STL/FBD Editor) 中的菜单命令“调试 > 监
视”(Debug > Monitor)。 

可监视对您的程序的影响。 



 入门指南 
 3.7 使用帮助 

S7-PLCSIM V5.4 
操作手册, 07/2011, A5E03432190-03 31 

3.7 使用帮助 

简介                  

您可以通过“帮助”(Help) 菜单或采用以下方式访问 S7-PLCSIM 在线帮助： 

● 要在 S7-PLCSIM 窗口中获取某一对象的帮助信息，请在工具栏上单击“帮助”(Help) 按
钮 ，然后单击此对象。 

● 要获取任意对话框或错误消息的帮助，请单击此对话框或消息框中的“帮助”(Help) 按
钮，或者按 F1。 

“帮助”(Help) 窗口提供以下按钮、菜单命令以及选项卡： 

帮助按钮 

● 隐藏按钮/显示按钮： 切换导航区的显示（“目录”(Table of Contents)、“索引”(Index) 
以及“搜索”(Search) 选项卡）。 要减小帮助窗口的整体大小，您可以隐藏导航区；在

准备查看新主题时，请单击“显示”(Show) 按钮以恢复此导航区。 

● 后退按钮： 如果已查看了多个主题，则通过此按钮，您可以后移至先前主题。 

● 前进按钮： 如果已查看了多个主题，则通过此按钮，您可以前移至下一主题。 

● 主页： 打开定义为 S7-PLCSIM 在线帮助主页的网页。 

● 打印按钮： 允许您向已安装的打印机发送所选主题或整本书。 

帮助浏览器选项卡 

● 目录选项卡： 选择此选项卡以查看帮助系统中的目录。 双击任意书本图标，以展开

此书并查看书中包含的主题。 

● 索引选项卡： 选择此选项卡以查看按字母数字排序的帮助系统索引关键字列表。 

● 搜索选项卡： 选择此选项卡，然后输入您希望查找的字词。 双击列表中的主题以查

看该主题。 默认情况下，在主题中，将在字词出现的位置高亮显示字词，以便于找到

字词。 在显示主题前，您可以在关闭和打开高亮显示之间进行切换。 使用“选
项”(Options) 按钮执行此操作。 
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仿真任务 4
4.1 附加符号 

原有方法*** 

到目前为止，可从“选择 CPU 访问节点”(Select CPU Access Node) 对话框中附加符号。 
要使用此 STEP 7 项目中的符号，您必须选中“附加符号”(Attach Symbols) 复选框。 

步骤 

要使用项目中的符号，请进行以下操作： 

1. 启动仿真。 

2. 选择菜单命令“工具 > 选项 > 附加符号”(Tools > Options > Attach Symbols)，或单击 
。 

将打开“打开”(Open) 对话框。 

 

3. 导航至相应项目或库条目。 

4. 选择符号。 

5. 单击“确定”(OK) 进行确认。 

符号已附加。 
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参见 

使用符号寻址 (页 49) 

4.2 .PLC 文件和 .LAY 文件之间的区别是什么？ 

PLC 文件 

文件 *.PLC 用于保存仿真 PLC。 将保存以下信息： 

● 程序 

● 硬件配置 

● 工作模式 

● I/O 的当前状态 

LAY 文件 

*.LAY 文件用于保存 S7-PLCSIM 中工作区的当前窗口排列。 如果以某种顺序排列您的视

图对象，并且希望为以后的工作会话保留此顺序，则请在关闭 S7-PLCSIM 之前保存此布

局。  

打开顺序 

在使用 S7-PLCSIM 时，您可以同时打开 .PLC 文件和 .LAY 文件。 

1. 打开仿真 PLC（.PLC 文件）。 

2. 然后打开布局（.LAY 文件）。 
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4.3 保存仿真 PLC 

保存的数据 

在您保存 PLC 时，会保存以下数据： 

● 程序 

● 硬件配置 

● 仿真子网和节点 

● CPU 工作模式（钥匙开关位置）的复选框选项： 即 RUN-P、RUN 或 STOP 

● 扫描模式选项（持续扫描、单次扫描） 

● I/O 状态 

● 定时器值（T 存储器） 

● 符号地址 

● 电源开/关设置 

步骤 

要在当前文件名称下保存仿真当前状态的 PLC，请进行如下操作： 

1. 选择菜单命令“文件 > 保存 PLC”(File > Save PLC)。 

使用菜单命令“文件 > PLC 另存为”(File > Save PLC As) 以将 PLC 组态存档到一个新

文件中。 

2. 要显示符号地址，请使用“工具 > 选项 > 显示符号”(Tools > Options > Show Symbols) 
命令。 

结果 

S7-PLCSIM 将您的文件保存到 STEP 7 的相关项目目录中。 

如果不存在任何可用于仿真的项目数据（例如： 默认 CPU），则将 PLC 文件保存到以

下路径下： [安装目录]\Siemens\PLCSIM\S7WSI\Archive 
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4.4 保存布局命令 

简介 

布局仅是 视图对象 (页 59)的一种排列。 .LAY 文件仅存档仿真中的视图对象位置以及所

选数据格式。 视图对象中显示的数据值不属于布局保存部分。 

步骤 

要保存 S7-PLCSIM 中的视图对象的当前位置，请进行如下操作： 

1. 选择菜单命令“文件 > 布局另存为”(File > Save Layout As)。 

选择菜单命令“文件 > 保存布局”(File > Save Layout) 以将布局保存到当前文件中。 

将打开“布局另存为”(Save Layout As) 对话框。 

2. 通过“保存”(Save) 进行确认。  

结果 

S7-PLCSIM 将您的文件保存到 STEP 7 的相关项目目录中。 

如果不存在任何可用于仿真的项目数据（例如： 默认 CPU），则将 PLC 文件保存到以

下路径下： [安装目录]\Siemens\PLCSIM\S7WSI\Archive  

4.5 打开仿真 PLC 

要求 

● 先前已在 PLC 文件中保存此仿真 PLC。 

● 此文件不属于只读文件。 

● 未在其他应用程序中打开此文件。 
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步骤 

要打开现有 PLC 仿真，请进行如下操作： 

1. 选择下列选项之一： 

– 选择“仿真 > 最近仿真”(Simulation > Recent Simulation) 菜单命令，然后选择已保

存的 PLC 条目。 

– 选择“文件 > 打开 PLC”(File > Open PLC) 菜单命令，然后浏览到并选择现有 .PLC 
文件。 

2. 单击“确定”(OK) 进行确认。 

  说明 
如果弹出一个表示此文件属于只读文件因而无法打开的对话框，则必须使用 Windows 
资源管理器移除此文件的只读标志。 

旧版本文件 

要打开 S7-PLCSIM V5.3 版本或更早版本的文件，S7-PLCSIM 必须将此文件转换为当前

文件格式。 转换期间，将创建带有扩展名 *.BAK 的原始文件备份副本。 然后，将原始 
PLC 文件转换为当前格式。 如果已存在只读备份文件，则转换将失败。 如果出现这种情

况，请使用 Windows 资源管理器删除先前存在的备份文件，然后在 S7-PLCSIM 打开

此 .PLC 文件。 

在某些情况下，S7-PLCSIM 将无法打开旧版本 .PLC 文件。 包含多 DP 网络、热备份系

统或容错 CPU 的仿真文件可能无法与 S7-PLCSIM V5.4 兼容。 
 

 说明 
在打开新的或已存档的 PLC 仿真时，在 S7-PLCSIM 中显示的所有视图对象均会自动关

闭。 如果您想要打开已存档布局以及新的或已存档 PLC 仿真，则请先打开仿真 PLC，之

后再打开布局。 
 

打开后的工作模式 

打开已存档的仿真 PLC 时，将恢复已保存的工作模式。 
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4.6 打开布局命令 

简介 

布局属于视图对象的一种排列。 *.LAY 文件仅存档仿真中的视图对象位置以及所选数据格

式。 视图对象中显示的数据值不属于布局保存部分。 

要求 

● 先前已在 LAY 文件中保存此布局。 

步骤 

要打开布局，请进行如下操作： 

1. 选择下列选项之一： 

– 选择菜单命令“仿真 > 最近布局”(Simulation > Recent Layout)，然后选择布局。 

– 选择“仿真 > 打开布局”(Simulation > Open Layout) 菜单命令，然后浏览到并选择现

有 *.LAY 文件。 

2. 选择“仿真 > 打开布局”(Simulation > Open Layout) 菜单命令，将打开“打开”(Open) 对
话框。 

3. 导航至文件的存储位置。 

4. 选择文件。 

5. 单击“打开”(Open) 进行确认。 

将打开布局。 
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4.7 选择扫描模式 

简介  

有 2 个选项可用于运行仿真程序： 

● 单次扫描： CPU 执行一次扫描，然后等待您初始化其他扫描。 每次扫描包括 CPU 
读取外设输入 (PI)、执行程序以及之后将结果写入外设输出 (PQ)。 然后 CPU 等待运

行下一扫描的命令。 通过每次执行程序时扫描一次，您可以查看各扫描中的变更内

容。 由于“真正的”CPU 在显示数据时执行速度要比编辑器快的多，因此，在从一个扫

描到另一扫描时，单次扫描选项允许您“冻结”程序的状态。 

● 持续扫描： CPU 执行一次完整扫描后，开始另一个扫描。 每次扫描包括 CPU 读取

外设输入 (PI)、执行程序以及之后将结果写入外设输出 (PQ)。 

默认设置为“持续扫描”(Continuous Scan)。 

步骤 

要设置“单次扫描”模式，请按如下步骤操作： 

1. 单击 ，或选择菜单命令“执行 > 扫描模式 > 单次扫描”(Execute > Scan Mode > 
Single Scan)。 

2. 要运行下一扫描，请选择菜单命令“执行 > 下一扫描”(Execute > Next Scan) 或 。 

要设置“持续扫描模式”，请进行如下操作： 

1. 单击 ，或选择菜单命令“执行 > 扫描模式 > 持续扫描”(Execute > Scan Mode > 
Continuous Scan)。 



仿真任务  
4.8 切换 CPU 工作模式 

 S7-PLCSIM V5.4 
40 操作手册, 07/2011, A5E03432190-03 

4.8 切换 CPU 工作模式 

简介 

类似于“真正”PLC，仿真 PLC 会对工作模式的切换作出响应。 仿真 PLC 的“CPU”视图对

象中的 LED 显示当前工作模式。 

步骤 

要切换 CPU 工作模式，请进行如下操作： 

1. 单击对应复选框，或选择菜单命令“执行 > 钥匙开关位置 > [模式](Execute > Key 
Switch Position > [mode])。 

CPU 将切换工作模式。 

对比真正 CPU 

仿真 CPU 中的 CPU 工作模式类似于真正 CPU 中的钥匙开关： 如果您使用 STEP 7 工
具切换工作模式，或者如果 CPU 会自动切换模式（例如，遇到将导致 CPU 从 RUN 模式

切换到 STOP 模式的错误情况），则仿真 CPU 视图对象中的复选框不会发生变化。 
LED 指示灯会发生变化，但钥匙开关不会。 这提醒您 CPU 已切换了工作模式，可能是

因为程序中的某个错误。  
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4.9 仿真 STEP 7 用户程序 

视图对象         

您可以显示允许您监视以及修改运行在仿真 PLC 中的 STEP 7 用户程序的不同类型视图

对象。 

S7-PLCSIM 提供可用于监视以及修改程序对象的视图对象。 您还可以使用符号寻址来寻

址这些视图对象。 以下是从“插入”(Insert) 菜单中激活的视图对象： 

● 输入变量 (页 64) 

● 输出变量 (页 65) 

● 位存储器 (页 66) 

● 定时器 (页 66) 

● 计数器 (页 67) 

● 通用 (页 67) 

● 垂直位 (页 68) 

以下是从“视图”(View) 菜单中激活的三个视图对象： 

● 累加器 (页 62) 

● 块寄存器 (页 62) 

● 堆栈 (页 63) 

步骤 

同样要在 STEP 7“LAD/STL/FBD”应用程序中同步监视程序，请进行如下操作： 

1. 在 SIMATIC Manager 中，单击 ，或选择“视图 > 联机”(View > Online) 以切换到联

机模式。 

2. 导航至 STEP 7 项目的“块”(Blocks) 对象，然后打开一个逻辑块。 （示例： 在 
S7_ZEBRA 示例项目中打开 FC1）。 

“LAD/STL/FBD”应用程序显示仿真 PLC 正在执行的程序。 使用此菜单命令查看指令的

状态。 
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4.10 滚动条控件 

简介 

“滚动条控件”是一种对于不同 数值格式 (页 87)均可用的工具。 使用数字键盘无法输入的

值可通过滚动条控件进行输入。 

 

未使用滚动条控件 使用滚动条控件 

  

 

仿真值 

 通过滚动条控件，您可以仿真逐步变化的或者某个特定范围内的值，如模拟值。          



 仿真任务 
 4.10 滚动条控件 

S7-PLCSIM V5.4 
操作手册, 07/2011, A5E03432190-03 43 

步骤 

要使用滚动条控件，请进行如下操作： 

1. 为可用滚动条控件选择以下视图对象之一。 

– 输入变量 (页 64) 

– 输出变量 (页 65) 

– 位存储器 (页 66) 

2. 您可以使用存储器地址或 符号地址 (页 49)访问存储区。 

3. 要为其中某一个视图对象指定滚动条控件，请从“选择数值格式”(Select Numeric 
Format) 下拉列表中选择滚动条控件表示。 

4. 选择将值表示为十进制（正整型）、整型（正整型以及负整型）还是实数型。 

根据要访问的存储单元大小决定选择选项： 

– 字节 (B)： 十进制 

– 字 (W)： 十进制和整型 

– 双字 (D)： 十进制、整型和实型 

5. 您可以使用鼠标或箭头键更改滚动条控件指示器的位置，或者在“值”(Value) 字段中输

入具体值。 

存储在存储单元的变量值会发生变化。 

组态一个最小值和一个最大值 

要为滚动条选择最小值，请从视图对象的“显示最小值或最大值”(Display Value, Min, or 
Max) 下拉列表中选择“最小值”(Min)。 然后，在“最小值”(Min) 字段中为最小值输入数值。 

要为滚动条选择最大值，请从视图对象的“显示最小值或最大值”(Display Value, Min, or 
Max) 下拉列表中选择“最大值”(Max)。 然后，在“最大值”(Max) 字段中为最大值输入数

值。  
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值范围的优势 

选择值范围具有以下优势： 

● 值范围不会影响可存储在变量中的值。 最小值和最大值仅影响可由滚动条控件输入或

显示的值。 

● 您可以仿真值的具体范围，例如，特定模拟量模块生成的值范围。 

● 通过限制最小值和最大值之间的值范围，您可以为使用滚动条控件输入数据提供更好

的解决方案。 您始终能够在视图对象的“值”(Value) 字段中输入准确值。 

4.11 调试程序 

测试功能  

S7-PLCSIM 提供以下功能以帮助您调试您的程序： 

● “暂停”(Pause) 命令立即中断仿真 CPU，并允许您从程序暂停的指令处继续执行程

序。 

● 您对 视图对象 (页 59)所作的任何更改会立即更新存储单元中的内容。 CPU 不会等到

扫描开始或结束才更新所有已更改数据。 

● 扫描模式 (页 39)选项允许您选择 CPU 运行程序的方式： 

– 单次扫描： 针对一次扫描执行程序，然后等待您启动下一次扫描。 

– 持续扫描： 像“真正的”PLC 一样执行程序： 它在前一扫描完成后会立即启动新的扫

描。 
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4.12 使用程序中的错误 OB 

简介 

您可以使用 S7-PLCSIM 测试您的程序如何处理不同中断 OB。 

要求 

为了能够仿真错误 OB，您必须将对应硬件配置下载到 S7-PLCSIM 中。 

步骤 

要触发错误 OB，请进行如下操作： 

1. 选择菜单命令“执行 > 触发错误 OB”(Execute > Trigger Error OB) 

2. 选择指定 OB。 

将打开此 OB 的对话框。 

3. 选择相应选项。 

4. 单击“确定”(OK) 或“触发”(Trigger) 进行确认。 

结果 

仿真 PLC 生成相应事件，并在相关 OB 中运行此程序。 
 

 说明 
在“触发错误 OB”(Trigger Error OB) 菜单中哪些 OB 可用取决于下载到仿真中的硬件配

置。 
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支持的 OB 

S7-PLCSIM 支持以下错误和中断 OB： 

● OB40 至 OB47 (页 71)（硬件中断） 

● OB70 (页 72)（I/O 冗余错误） {仅限 417-H 系统} 

● OB72 (页 73)（CPU 冗余错误） {仅限 417-H 系统} 

● OB73 (页 75)（通信冗余错误） {仅限 417-H 系统} 

● OB80 (页 75)（时间错误） 

● OB82 (页 76)（诊断中断） 

● OB83 (页 78)（插入/卸下模块） 

● OB85 (页 79)（优先级等级错误） 

● OB86 (页 80)（机架故障） 

S7-300 CPU 

当在 S7-PLCSIM 中仿真错误和中断 OB 时，需要项目 PI/PQ 信息。 S7-300 系列的大多

数 CPU 均自己组态 I/O。 如果模块已连接到控制器上，则 CPU 将自动检测此模块。 仿
真 PLC 无法仿真自动组态功能。 如果将程序从自动组态 I/O 的 S7-300 CPU 下载到 S7-
PLCSIM 上，则系统数据中不包含 I/O 组态。 因此，首先您必须将已组态 I/O 模块的硬件

配置下载至系统数据中。 这样，您可以定义哪些 CPU 模块可用。 

要执行此操作，请创建一个项目，然后组态 S7-300 CPU（其中未自动组态 I/O），例如 
CPU 315-2DP、CPU 316-2DP 或 CPU 318-2。将此硬件配置下载到 S7-PLCSIM 中。 
然后您可以下载任意 S7 程序中的程序块。 应用这些 I/O 时不会出现错误。  
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4.13 复位 CPU 存储器 

简介 

复位的影响如下： 

● 复位存储区 

● 删除程序块 

● 删除仿真 PLC 的硬件配置 

步骤 

要复位仿真 CPU 的存储器，请进行如下操作： 

1. 选择菜单命令“PLC > 清除/复位”(PLC > Clear/Reset)，或单击 CPU 视图对象上的 
MRES 按钮。 

将打开“清除/复位”(Clear/Reset) 对话框。 

2. 单击“是”(Yes) 进行确认。 

CPU 自动转至 STOP 模式，且所有现有连接均断开。 
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4.14 复位定时器 

步骤 

要复位程序中的定时器，请进行如下操作：    

1. 选择菜单命令“执行 > 复位定时器”(Execute > Reset Timers) 

将打开“复位定时器”(Reset Timers) 对话框。 

2. 选择下列选项之一： 

– 选择“全部定时器”(All Timers) 以复位程序中的所有定时器 

– 选择“特定计时器”(Specific Timer) 以指定要复位的特定计时器。 

3. 单击“确定”(OK) 进行确认。 

将复位此定时器 

备选方法 

此外，“CPU 模式”(CPU Mode) 工具栏也提供了用于复位定时器的按钮。  

● 要复位程序中的所有定时器，请使用“复位定时器”(Reset Timers)  工具栏按钮。 

● 要复位单个定时器，请使用与该定时器对应的视图对象上的“复位计时器”(Reset Timer) 
 按钮。 

手动定时器命令（执行菜单）    

选择菜单命令“执行 > 手动定时器”(Execute > Manual Timers) 以设置 CPU，以便您能够

输入特定值，或复位程序中的定时器。 选择菜单命令“执行 > 自动定时器”(Execute > 
Automatic Timers) 以返回到自动运行定时器 

4.15 为仿真 CPU 接通/断开电源 

步骤 

要为仿真 CPU 接通/断开电源，请进行如下操作：    

1. 选择“PLC > 接通电源”(PLC > Power On) 以及“断开电源”(Power Off) 菜单命令以仿真 
CPU 电源的接通和断开。 
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4.16 使用符号寻址 

简介 

在默认情况下，S7-PLCSIM 使用已加载的 STEP 7 程序的符号。 如果在启动仿真后未附

加符号，或者想要使用其它 STEP 7 程序中的符号，则可指定要附加的符号表。        

步骤 

要在仿真的程序中使用符号寻址，请按以下步骤操作： 

1. 选择菜单命令“工具 > 选项 > 附加符号”(Tools > Options > Attach Symbols)。 

将打开“打开”(Open) 对话框。 

2. 浏览到要引用的 STEP 7 符号表的存储位置。 

3. 单击“确定”(OK) 进行确认。 

4. 为想要符号寻址的变量创建视图对象。 

5. 要打开所有视图对象的符号，请选择菜单命令“工具 > 选项 > 显示符号”(Tools > 
Options > Show Symbols)。 

要隐藏符号，请再次选择此命令。 

符号的工具提示 

使用符号寻址来监视程序时，所有已分配符号地址的视图对象字段均有工具提示。 用鼠

标指向字段可在工具提示框中看到其符号地址和注释（以冒号分隔）。 

参见 

垂直位变量视图对象 (页 68) 
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4.17 记录/回放 

简介 

通过“记录/回放”(Record/Playback) 对话框可记录或回放一系列数据变化。  

 

要求 

● CPU 处于 RUN 或 RUN-P 模式 

步骤 

要调用“记录/回放”(Record/Playback) 对话框，请按以下步骤操作： 

1. 选择菜单命令“工具 > 记录/回放”(Tools > Record/Playback) 或单击 “记录/回
放”(Record/Playback) 符号。 

将会打开该对话框。 

2. 要记录一系列事件，请单击“记录”(Record) 按钮。 

3. 要完成记录，请记住先使用“保存事件文件”(Save Event File) 按钮进行保存，然后再关

闭 S7-PLCSIM。 

  说明 
使用键序列 Alt + F5 可切换“记录/回放”(Record/Playback) 工具栏按钮的显示。 
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如何记录或回放事件文件 

 单击“新建事件文件”(New Event File) 按钮可创建新事件文件。 

 单击“打开事件文件”(Open Event File) 按钮可找到并打开现有事件文件。 

 单击“保存事件文件”(Save Event File) 按钮可保存刚记录的事件。 

 单击“播放”(Play) 按钮可回放现有事件记录。 

 单击“记录”(Record) 按钮可开始记录一系列事件。 使用仿真中的视图对象来根据需要

打开和关闭各个位或分配数据值。 记录器将捕获您对存储区所做的所有更改。 

 单击“暂停”(Pause) 按钮可临时停止记录或回放。 “暂停”(Pause) 功能非常方便，可用

于暂停记录事件并在稍后继续。 如果需要在完成事件生成之前执行一些其它活动（例

如，添加新视图对象或接电话），则可以单击“暂停”(Pause) 并从而避免记录中出现长延

迟。 使用“暂停”(Pause) 按钮可在记录时最大程度地缩短事件间的延时，而“增量”(Delta) 
按钮影响回放记录时的总速率。 

 单击“停止”(Stop) 按钮可停止事件的记录或回放。 

 通过“增量”(Delta) 按钮可在回放记录前选择速率。 您的选择将影响总体回放时间。 但
是，如果某些事件记录得太紧密或相互间隔时间较长，则相对的时间间隔将保留，即使通

过增量选择增加或减少总体回放时间。 

检查 

有两种方法可用来确认是否已成功记录或回放事件： 

● 检查“记录/回放”(Record/Playback) 对话框的状态栏，查看其正处于“记
录”(Recording)、“播放”(Playing) 还是“空闲”(Idle) 模式。 

● 查看“记录/回放”(Record/Playback) 对话框的标题栏。 标题栏应显示一个数值，每次

记录或回放事件时该数值将增加。 
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故障排除提示 

 

问题 解决方案 

“播放”(Play)  按钮被禁

用，无法回放记录。 
必须先打开一个事件文件，然后才能回放事件记录。 请使用“打开事件文

件”(Open Event File) 按钮选择并打开事件文件。 

我在记录了一系列事件后

关闭 S7-PLCSIM。 下次

打开 S7-PLCSIM 时，无

法找到这些事件。 

如果在未将记录的事件保存到事件文件的情况下关闭 S7-PLCSIM，所做的工作

将丢失。 请使用“保存事件文件”(Save Event File)  按钮保存所做的工作，然

后关闭 S7-PLCSIM。 

我记录了一系列事件，但

在尝试回放它们时，没有

任何反应。 

检查“记录/回放”(Record/Playback) 对话框的状态栏来查看当前所处的模式。如

果显示的是“播放”(Playing)，则查看标题栏上何时有数值显示。 回放事件时，

标题栏中的计数器会记录已回放的事件数。 请注意，如果启动一个记录后没有

立即开始触发事件，记录器将捕获时间延迟。 回放该记录时，第一个事件将在

同样长的时间后才会开始。 您可以检查事件文件以验证是否实际上已正确记录

事件。 可使用“增量”(Delta)  按钮来调整记录的回放速度。 

我不记得哪个事件文件包

含我想要回放的事件序

列。 

您可以使用具有描述性的长文件名来帮助区分事件文件。 如有必要，可使用文

本编辑器来检查文件，并找到具有正确序列的事件文件。 事件文件的默认存储

位置为 [程序文件夹]\Siemens\PLCSIM\S7wsi\events。 

我只更改了一个位，但在

回放记录时，整个字节都

被更改了。 

如果输入变量、输出变量、位存储器、通用变量或垂直位视图对象仅显示一个

位（例如，Q0.0，位），则特定位上的更改将被正确记录。 但是，如果视图对

象显示所有八个位（例如，QB0，位），则单个位的更改将被记录为字节值的

更改，而不仅是对该位的更改。 因此，在回放记录过程中，可能会出现字节内

的其它位显示为已更改的情况（例如，过程标记或布尔输入），但实际上，在

真实 PLC 的运行过程中这些位不会受到影响。 
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问题 解决方案 

试图在单次扫描模式下记

录事件时，记录器并不按

照所期望的方式工作。 

在单次扫描模式下记录带有 CPU 视图对象的事件时，请注意以下事项： 

只有单击“下一扫描”(Next Scan)  按钮来增加扫描计数后才能在单次扫描模

式下开始记录。 记录的第一个事件的增量值必须为 1 或更高。 增量值基于从

上一事件（这种情况下为单击“记录”(Record) 按钮时）以来已发生的扫描周期

数。 但是，如果要在单次扫描模式下开始记录，则仍然尚未经过任何扫描周

期。 必须增加扫描周期数。 

在单次扫描模式下记录多个事件时，这些事件的增量值为零（因为它们都在同

一次扫描中发生）。 因此，在回放该记录时，在单次扫描过程中记录的所有事

件会以非常快的顺序显示，看起来像是同时发生一样。 要在事件之间增加可辨

别的时间延迟，必须对每个事件都单击“下一扫描”(Next Scan) 按钮或在持续扫

描模式和单次模式之间切换。 

我的事件文件包含德语助

记符，尽管我并未在 
STEP 7 中选择。 

无论 STEP 7 的选择如何，在 S7-PLCSIM 中均使用德语助记符记录事件。 您
可以忽略此情况。 

4.18 监视周期时间 

简介 

在 S7-PLCSIM 中执行程序可能会比使用实际 CPU 执行慢很多（尤其是当其它应用程序

以较高优先级运行时）。 您可能会因此而遇到恼人的超时情况。 您可以使用本对话框禁

用或延长扫描周期的监视过程，而无需修改用于目标 PLC 的程序。 

步骤 

要监视扫描周期，请按以下步骤操作： 

1. 选择菜单命令“执行 > 扫描周期监视”(Execute > Scan Cycle Monitoring) 

将打开“扫描周期监视”(Scan Cycle Monitoring) 对话框。 

2. 激活“启用扫描周期监视”(Enable Scan Cycle Monitoring) 选项。 

3. 输入监视时间，可以是介于 1 秒 (1000 ms) 和 1 分钟 (60000 ms) 之间的任意值（包

括 1 秒和 1 分钟）。 

默认的扫描周期监视时间是 6000 ms。 

4. 单击“确定”进行确认 
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定义 - 最大扫描周期时间 

最大扫描周期时间是指完整扫描一次 OB1 中的 S7 用户程序以及更新相应 I/O 的过程所

允许使用的最长时间。如果超过此时间，仿真 PLC 将进入 STOP 模式。 
 

 说明 
请注意，“扫描周期监视”(Scan Cycle Monitoring) 对话框并不反映硬件配置中设置的监视

时间。 更改只会影响仿真。 
 

4.19 关闭仿真 PLC 

简介 

关闭仿真 PLC 时，会自动生成一个处于原始状态的新 CPU。 

要求 

● 仿真已保存 (页 35)。 

步骤 

要关闭程序的仿真，请按以下步骤操作： 

1. 选择菜单命令“文件 > 关闭 PLC”(File > Close PLC)。 

结果 

仿真的子网、节点和所有已打开的视图对象都将被关闭。 会自动打开一个处于原始状态

的新 PLC。 
 

 说明 
关闭仿真程序可导致当前与仿真器连接的应用程序出错。 
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4.20 关闭布局 

简介 

关闭布局不会结束仿真会话。 当前 PLC 仍保持打开状态。 S7-PLCSIM 仍处于激活状

态。 您可以打开另一个布局。 

要求 

● 布局已保存 (页 36)。 

步骤 

要关闭程序的布局，请按以下步骤操作： 

1. 选择菜单命令“文件 > 关闭布局”(File > Close Layout)。 

除“CPU”外的所有视图对象都将被关闭。 
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4.21 结束仿真 

简介 

结束仿真将结束仿真会话。 S7-PLCSIM 将被关闭。 

要求 

● 保存仿真 PLC (页 35) 

● 保存布局命令 (页 36) 

步骤 

要结束仿真，请进行如下操作： 

1. 关闭所有与监视仿真相关的 STEP 7 应用程序。 

2. 选择菜单命令“文件 > 退出”(File > Exit)。 

仿真的子网、节点和所有已打开的视图对象都将被关闭。 

  说明 
退出 S7-PLCSIM（如关闭仿真 PLC）可导致当前与仿真连接的应用程序出错。 
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4.22 仿真 T-CPU 

简介 

S7-PLCSIM 可以仿真控制程序（例如为 CPU S7-317T 开发的控制程序），但有一定限

制。 

特性      

仿真过程中不会访问任何运动控制设备。 调用运动控制函数块仅会返回到执行调用的

块，并进行一些有限的错误检查。 错误检查包括： 

● 是否存在背景数据块 

● 是否存在工艺数据块 

● 对已定义范围的参数进行范围检查 

如果输入参数有效（例如：CPU S7-317T），S7-PLCSIM 将为其中一些 MC 命令设置参

数： 

 

MC 命令 参数 设定值 

MC_Power Statusword.DriveEnabled 
Statusword.Standstill 

（工艺数据块参数） 

启用时为真，禁用时为假 
真 

MC_Stop Statusword.Stopping 
Statusword.Standstill 

（工艺数据块参数） 

真 
真 

MC_MoveAbsolute 
(MC_MvAbs) 

Position 输入参数位置 

MC_ExternalEncode
r 
(MC_ExEnc) 

Position 输入参数位置 
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视图对象 5
 

简介 

S7-PLCSIM 提供了多种视图对象，可用于监视和修改仿真 PLC 的各个组件。 这些视图

对象列出如下：      

● CPU (页 60) 视图对象 

● ACCU 和状态字 (页 62)视图对象 

● 块寄存器 (页 62)视图对象 

● 视图对象 “堆栈” (页 63) 

● 输入变量 (页 64)视图对象 

● 输出变量 (页 65)视图对象 

● 位存储器 (页 66)视图对象 

● 定时器 (页 66)视图对象 

● 计数器 (页 67)视图对象 

● 通用 (页 67)视图对象 

● 垂直位 (页 68)视图对象 

视图对象中的符号寻址 

对于视图对象，可使用 符号寻址 (页 49)。 如果执行此操作，所有已分配符号地址的视图

对象字段均有工具提示。 用鼠标指向字段可在工具提示框中看到其符号地址和注释（以

冒号分隔）。 

 
 

 说明 
如果在视图对象中使用的地址与 F 系统外设 I/O 相对应，则 S7-PLCSIM 在显示该视图对

象时会带有黄色背景。 
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5.1 CPU 视图对象 

简介 

默认情况下，在打开新仿真时会显示此视图对象。   

功能 

● 显示状态 

● 更改工作模式 

● 通过 MRES 复位存储器 

● 通过 MRES 删除块和硬件配置 

  说明 
CPU 视图对象的工作模式类似于真正 CPU 上的钥匙开关： 如果使用 STEP 7 工具切

换工作模式，或者如果 CPU 会自动切换模式（例如，遇到将导致 CPU 从 RUN 模式

切换到 STOP 模式的错误情况），则 RUN/STOP 指示灯也将发生变化。 钥匙开关不

会发生变化。 这提醒您 CPU 已切换了工作模式，可能是因为程序中的某个错误。 

5.1.1 CPU 工作模式开关位置 

RUN-P         

CPU 运行程序，您可更改该程序及其参数。 为了能在程序运行时使用 STEP 7 工具修改

该程序的任何参数，必须将 CPU 置于 RUN-P 模式下。 可以使用在 S7-PLCSIM 中创建

的视图对象来修改程序所使用的任意数据。 

选择 RUN-P 时，CPU 视图对象和 STEP 7 上的工作模式状态指示灯将显示 RUN。 

RUN 

CPU 通过读取输入，执行程序，然后更新输出的方式来运行程序。 默认情况下，当 CPU 
处于 RUN 模式时无法下载任何程序或使用 STEP 7 工具更改任何参数（例如输入值）。 
但是，如果在 STEP 7 项目中组态了 CiR（运行中组态）元素，则可以在 RUN 模式中下

载 CiR 对象。 对于处于 RUN 模式的仿真 CPU，可以使用在 S7-PLCSIM 中创建的视图

对象来修改程序所使用的任意数据。 
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STOP 

CPU 不运行程序。 与真正 CPU 的 STOP 模式不同，各输出不会被设置为预定义的（“安
全”）值，而是保持为 CPU 切换到 STOP 模式时所处的状态。 当 CPU 处于 STOP 模式

时，可将程序下载到 CPU 中。 从 STOP 模式切换到 RUN 模式时将从第一个指令开始执

行程序。 

CPU 工作模式、CPU 指示灯 (页 61)和 “存储器清除/复位”(Memory Clear/Reset) (页 47) 
按钮都显示在  CPU 视图对象 (页 60)上。 可使用“钥匙开关位置”(Key Switch Position) 命
令设置 CPU 工作模式。 在 CPU 处于 RUN 或 RUN-P 模式时，可暂停执行仿真 PLC 程
序。  

5.1.2 CPU 指示灯 

显示仿真 CPU         

CPU 显示对象 (页 60)提供了一组与真正 CPU 上的 LED 指示灯相对应的指示灯： 

● SF（系统故障）提示您 CPU 遇到系统错误，并导致工作模式改变。 

● DP（分布式外围设备或远程 I/O）指示与分布式（远程）I/O 的通信状态。 

● DC（电源）指示 CPU 的电源处于打开还是关闭状态。 

● RUN 指示 CPU 是否处于 RUN 模式。 

● STOP 指示 CPU 是否处于 STOP 模式。 
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5.2 ACCU 和状态字视图对象 
要将此视图对象添加到仿真中，请按以下步骤操作：       

● 选择菜单命令“视图 > 累加器”(View > Accumulators) 

● 单击“CPU 累加器”(CPU Accumulators) 按钮：  

功能 

通过此视图对象可监视和修改以下数据： 

● 累加器： 允许您监视 CPU 累加器的内容。 此视图对象显示四个累加器字段，还可以

适应 S7-400 CPU 的程序；S7-300 CPU 的程序仅使用两个累加器。 

● 状态字： 允许您监视状态字的各个位。 

● 地址寄存器： 允许您监视两个地址寄存器（AR1 和 AR2）的内容。 这些地址寄存器

用于数据的间接寻址。 

5.3 块寄存器视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：   

● 选择菜单命令“视图 > 块寄存器”(View > Block Registers) 

● 单击“块寄存器”(Block Registers) 按钮：  

功能 

通过此视图对象可监视数据块地址寄存器（DB1 和 DB2）的内容。 此视图对象还会显示

当前逻辑块和前一个逻辑块的编号，以及各个块的指令编号（步骤地址计数器，即 
SAC）。  
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5.4 嵌套堆栈视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：      

● 选择菜单命令“视图 > 堆栈”(View > Stacks) 

● 单击“堆栈”(Stacks) 符号：  

功能 

通过此视图对象可监视存储在 CPU 以下堆栈中的信息： 

● 嵌套堆栈最多可存储七个条目。 对于每个条目，嵌套堆栈都会存储状态字的 RLO 和 
OR 位的状态。 对于每个发起新逻辑字符串的指令，都会在嵌套堆栈中为其创建一个

条目。 这些指令包括： 与 (A)、与非 (AN)、或 (O)、或非 (ON)、异或 (X) 和异或非 
(XN)。 

● MCR 堆栈最多可存储八层主控制继电器 (MCR) 嵌套。 每个层都显示 MCR 指令（该

指令建立 MCR 区域）的 RLO 位的状态。 
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5.5 输入变量视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：        

● 选择菜单命令“插入 > 输入变量”(Insert > Input Variable) 

● 单击“插入输入变量”(Insert Input Variable) 按钮：  

  说明 
CPU 会对此视图对象的任何变化立即做出反应。 （对 STEP 7 变量表进行的任何修改

都将在 CPU 扫描中的适当时间生效： 扫描开始时读取输入，结束时写入输出。） 

功能 

通过此视图对象可监视和修改以下数据： 

● 外设（外部）输入变量： 您可访问 CPU 的外设输入 (PI) 存储器区域。 如果变量地址

与 F 系统外围 I/O 相对应，则 S7-PLCSIM 在显示该视图对象时会带有黄色背景。 

● 输入过程映像： 您可访问 CPU 的输入 (I) 存储器区域。 默认情况下，CPU 会在每次

扫描开始时用 PI 存储器覆盖 I 存储器。 如果更改 I 存储器的值，则仿真会立即将更改

值复制到外设区域。 这样，在下一次扫描中外设值覆盖过程输入值时，所需的更改不

会丢失。 

  说明 
您可以选择输入变量的数值数据格式，而且如果附加了符号，还可以使用符号寻址。 
您还可以通过垂直位视图对象查看输入变量。 

如果通过 CP 卡进行连接，则 S7-PLCSIM 不支持 S7-300 PI 和 PQ 的显示 

如果 PI 和 PQ 通过 CP 卡连接，则 S7-PLCSIM 无法显示仿真 S7-300 的 PI 和 PQ。 S7-
300 的 CP 卡的组态与 S7-400 不同。S7-PLCSIM 仅支持 S7-400 的 CP 卡组态。 
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5.6 输出变量视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：        

● 选择菜单命令“插入 > 输出变量”(Insert > Output Variable) 

● 单击“插入输出变量”(Insert Output Variable) 按钮：  

  说明 
CPU 会对此视图对象的任何变化立即做出反应。 （对 STEP 7 变量进行的任何修改都

将在 CPU 扫描中同时生效： 扫描开始时读取输入，结束时写入输出。） 

功能 

通过此视图对象可监视和修改以下数据： 

● 外设（外部）输出变量： 您可访问 CPU 的外设输出 (PQ) 存储器区域。 PQ 存储器

值的任何变化都会立即更新相应的输出 (Q) 存储器值。 如果变量地址与 F 系统外围 
I/O 相对应，则 S7-PLCSIM 在显示该视图对象时会带有黄色背景。 

● 输出过程映像： 您可访问 CPU 的输出 (Q) 存储器区域。 在扫描周期中，程序将计算

输出值并将这些值置于过程映像输出表中。 在扫描周期结束时，操作系统从此表中读

取计算出的输出值，并将其发送到过程输出。 过程输出映像表会映射外设输出存储器

的前 512 个字节（取决于 CPU）。 

  说明 
您可以选择输出变量的数值数据格式，而且如果附加了符号，还可以使用符号寻址。 
您还可以通过垂直位视图对象查看输出变量。 

如果通过 CP 卡进行连接，则 S7-PLCSIM 不支持 S7-300 PI 和 PQ 的显示 

如果 PI 和 PQ 通过 CP 卡连接，则 S7-PLCSIM 无法显示仿真 S7-300 的 PI 和 PQ。 S7-
300 的 CP 卡的组态与 S7-400 不同。S7-PLCSIM 仅支持 S7-400 的 CP 卡组态。 
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5.7 位存储器视图对象 
要访问此视图对象，请执行以下操作之一：    

● 选择菜单命令“插入 > 位存储器”(Insert > Bit Memory) 

● 单击“插入位存储器”(Insert Bit Memory) 按钮：  

功能 

通过此视图对象可监视和修改位存储器的以下内容： 

● 存储在 CPU 的位存储器 (M) 区域中的变量。 

● 用于存储程序中计算出的中间结果的位存储器 (M) 区域。 

● 用于访问数据的数据格式 

  说明 
您可以选择位存储器的数值数据格式，而且如果附加了符号，还可以使用符号寻址。 
您还可以通过垂直位视图对象查看位存储器。 

5.8 定时器视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：     

● 选择菜单命令“插入 > 定时器”(Insert > Timer) 

● 单击“插入定时器”(Insert Timer) 按钮：  

功能 

通过此视图对象可监视和修改程序使用的任何定时器。 定时器视图对象可显示定时器的

名称、定时器实际值和时基。 
 

 说明 
如果更改时基，则定时器实际值将发生变化，而所显示的值将保持不变。 这是因为定时

器实际值是显示值和时基的乘积。 例如，如果定时器 T 0 的值为 600 且时基为 10 ms，
则表示定时器为 6 秒。 如果将时基更改为 100 ms，则定时器实际值将变为 60 秒。 
（600 * 100 ms = 60 秒） 

 

如果附加了符号，则可以对定时器使用符号寻址。 还可以将定时器组态为自动或手动控

制。 使用“执行”(Execute) 菜单中的命令进行此操作。  
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5.9 计数器视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：    
● 选择菜单命令“插入 > 计数器”(Insert > Counter) 
● 单击“插入计数器”(Insert Counter) 按钮：  

功能 
通过此视图对象可监视和修改程序使用的计数器。 此视图对象打开时的默认存储器位置

为 C 0。 
您可以选择计数器的数值数据格式，而且如果附加了符号，还可以使用符号寻址。 

5.10 通用视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：    
● 选择菜单命令“插入 > 通用”(Insert > Generic) 
● 单击“插入通用变量”(Insert Generic Variable) 按钮：  
结果： 视图对象“变量”打开。 

功能 

通过此视图对象可监视和修改以下数据： 
● 外设（外部）输入和输出变量： 您可以访问 CPU 的外设输入 (PI) 和外设输出 (PQ) 

存储器区域。 如果变量地址与 F 系统外围 I/O 相对应，则 S7-PLCSIM 在显示该视图

对象时会带有黄色背景。 
● 过程映像输入和输出变量： 您可访问 CPU 的输入 (I) 和输出 (Q) 存储器区域。 默认

情况下，CPU 会在每次扫描开始时用 PI 存储器覆盖 I 存储器。 如果更改 I 存储器的

值，则仿真会立即将更改值复制到外设区域。 这样，在下一次扫描中外设值覆盖过程

输入值时，所需的更改不会丢失。 
● 位存储器： 您可访问存储在 CPU 的位存储器 (M) 区域中的变量。 
● 定时器和计数器： 您可访问程序使用的定时器和计数器。 
● 数据块： 您可以访问存储在程序数据块中的数据，例如 DB1.DBX 0.0 或 DB1.DBW 

0。 
CPU 会对此视图对象的任何变化立即做出反应。 对 STEP 7 变量表进行的任何修改都将

在 CPU 扫描中的适当时间生效；扫描开始时读取输入，结束时写入输出。 
您可以选择通用变量的数值数据格式，而且如果附加了符号，还可以使用符号寻址。 
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5.11 垂直位变量视图对象 
要将此视图对象添加到仿真中，请执行以下操作之一：      

● 选择菜单命令“插入 > 垂直位”(Insert > Vertical Bits) 

● 单击“插入垂直位”(Insert Vertical Bits) 按钮：  

结果： 视图对象“变量”打开。 

功能 

垂直位视图对象可使用位地址或字节地址。 您可以查看“垂直位”视图对象中所有位的符号

地址或绝对地址。 还可以监控以下数据： 

● 外设（外部）输入和输出变量： 您可以访问 CPU 的外设输入 (PI) 和外设输出 (PQ) 
存储器区域。 如果变量地址与 F 系统外围 I/O 相对应，则 S7-PLCSIM 在显示该视图

对象时会带有黄色背景。 

● 过程映像输入和输出： 您可访问 CPU 的输入 (I) 和输出 (Q) 存储器区域。 默认情况

下，CPU 会在每次扫描开始时用 PI 存储器覆盖 I 存储器。 如果更改 I 存储器的值，

则仿真会立即将更改值复制到外设区域。 这样，在下一次扫描中外设值覆盖过程输入

值时，所需的更改不会丢失。 

● 位存储器： 您可访问存储在 CPU 的位存储器 (M) 区域中的变量。 

● 数据块： 您可访问存储在程序数据块中的数据。 

CPU 会对此视图对象的任何变化立即做出反应。 对 STEP 7 变量进行的任何修改都将在 
CPU 扫描中同时生效。扫描开始时读取输入，结束时写入输出。 如果附加了用垂直位视

图对象表示的变量的符号，则可以使用符号寻址。  
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错误和中断 OB 6
 

简介 

S7-PLCSIM 支持以下错误和中断 OB：     

● OB40 到 OB47 (页 71)（硬件中断） 

● OB70 (页 72)（I/O 冗余错误）{仅限 417-H 系统} 

● OB72 (页 73)（CPU 冗余错误）{仅限 417-H 系统} 

● OB73 (页 75)（通信冗余错误）{仅限 417-H 系统} 

● OB80 (页 75)（时间错误） 

● OB82 (页 76)（诊断中断） 

● OB83 (页 78)（插入/卸下模块） 

● OB85 (页 79)（优先级等级错误） 

● OB86 (页 80)（机架故障） 

步骤 

要触发其中一个 OB 的仿真，请按以下步骤操作： 

1. 选择菜单命令“执行 > 触发错误 OB”(Execute > Trigger Error OB)。 

2. 选择所需的 OB 或 OB 组。 

有哪些 OB 可用取决于仿真中加载的硬件配置。 

  说明 
如果 OB 对话框已打开，则更改已加载到仿真中的系统数据将不会被考虑。 要使 OB 
使用更改的数据，必须关闭 OB 对话框并重新打开。 



错误和中断 OB  
6.1 逻辑基址 

 S7-PLCSIM V5.4 
70 操作手册, 07/2011, A5E03432190-03 

6.1 逻辑基址 

功能 

逻辑地址将用作模块的标识地址。 以下 OB 需要输入或输出模块的逻辑地址才能对其进

行识别： 

● OB40 - OB 47 

● OB82 

● OB83 

● OB86 

定义 

逻辑地址是可在 STEP 7 HW Config 中组态的已插入模块的最小地址。逻辑基址始终是最

小的整数地址。 

不同模块类型的逻辑地址 

逻辑起始地址取决于模块类型以及安装位置： 

 

 中央机架 Profibus 

输入模块 最小输入地址 
例如 PIB0 

最小输入地址 
例如 PIB0 

输出模块 最小输出地址 
例如 POB0 

最小输出地址 
例如 POB0 

I/O 模块 最小输入地址 
例如 PIB0 

最小模块地址（输入或输出） 
例如 PIB0 或 POB0 
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6.2 硬件中断（OB40 - OB47） 
通过对话框可触发中断 OB 并测试在 OB40 到 OB47 中下载的程序。  

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 说明 

模块地址 OB4x_MDL_ADDR WORD 触发中断的模块的 逻辑基址 (页 70)。 

模块状态 OB4x_POINT_ADD
R 

DWORD 
（十六进

制） 

对于数字模块： 具有模块各输入状态的位字段。 
（位 0 对应于第一个输入。） 
 
对于模拟模块、CP 或 FM： 模块的中断状态

（与用户无关）。 

中断 OB 
（只读） 

OB4x_OB_NUMBR BYTE OB 编号（40 到 47）。 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。 
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6.3 I/O 冗余错误 (OB70) 
通过此对话框可触发会导致调用 OB70 的 PROFIBUS-DP 冗余丢失。 仅当仿真中加载了 
H-CPU 的组态时，才能选择用于打开此对话框的菜单命令。       

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数（输入/输出） 变量 数据类型 说明 

错误事件类别 OB70_EV_CLASS BYTE 事件类和 ID： 

* B#16#72： 进入的事件 

* B#16#73： 离开的事件 

错误代码 OB70_FLT_ID BYTE 错误代码（可能值）： 

* B#16#A2 

* B#16#A3 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。 

还要输入以下参数： 

● DP 主站基址 

● DP 主站系统 ID 

● DP 从站基址 

● DP 站点编号 

字段条目必须与仿真 CPU 的 STEP 7 硬件配置中的值相匹配。 
 

 说明 
DP 从站基址、DP 站点编号和输入/输出选择仅适用于错误代码 0xA3。 
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6.4 CPU 冗余错误 (OB72) 
通过此对话框可触发会导致调用 OB72 的 CPU 冗余丢失。 仅当仿真中加载了 H-CPU 的
组态时，才能选择用于打开此对话框的菜单命令。 当发生以下事件之一时，H CPU 的操

作系统会调用 OB72：       

● CPU 冗余丢失 

● 备用站-主站切换 

● 同步错误 

● SYNC 模块错误 

● 数据更新中止 

● 比较错误（例如 RAM、PAA） 

在发生适当的启动事件后，所有处于 RUN 模式的 H CPU 都会执行 OB72。 

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 ID 

错误事件类别 OB72_EV_CLASS B#16#73 

  B#16#75 

  B#16#78 

  B#16#79 

错误代码 OB72_FLT_ID 参见故障 ID 表 
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OB72 故障 ID（错误代码） 

OB72_FLT_ID 中的错误代码指示了引起 OB72 调用的事件： 

 
OB72_FLT_ID  OB72 的启动事件 

B#16#01 由于 CPU 故障而导致冗余丢失（2 个中的 1 个） 
B#16#02 由于用户触发备用站 STOP 而导致冗余丢失（2 个中的 1 个） 
B#16#03 H 系统（2 个中的 1 个）切换到冗余模式 
B#16#20 RAM 比较出错 
B#16#21 比较过程映像输出值时出错 
B#16#22 比较存储器位、定时器或计数器时出错 
B#16#23 识别出不同的操作系统数据 
B#16#31 由于主站故障而导致备用站-主站切换 
B#16#33 由于操作员干预而导致备用站-主站切换 
B#16#34 由于同步模块连接问题而导致备用站-主站切换 
B#16#35 90“H_CTRL”触发了备用站-主站切换 
B#16#40 由于超过等待时间而导致用户程序出现同步错误 
B#16#41 由于在不同的同步点等待而导致用户程序出现同步错误 
B#16#42 由于在不同的同步点等待而导致操作系统出现同步错误 
B#16#43 由于超过等待时间而导致操作系统出现同步错误 
B#16#44 由于数据错误而导致操作系统出现同步错误 
B#16#50 缺少 SYNC 模块 
B#16#51 在未上电的情况下修改 SYNC 模块 
B#16#52 SYNC 模块已卸下/插入 
B#16#53 在未复位的情况下修改 SYNC 模块 
B#16#54 SYNC 模块： 机架号被分配了两次 
B#16#55 SYNC 模块出错/已消除 
B#16#56 SYNC 模块上设置了未授权的机架号 
B#16#C1 数据更新中止 
B#16#C2 由于在第 n 次尝试期间超出了监视时间而导致更新尝试中止（1 <= n <= 由于超出

监视时间而导致中止后所进行的更新尝试的最大可能次数）。 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 
S7-300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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6.5 通信冗余错误 (OB73) 
通过此对话框可触发容错 S7 连接的冗余丢失。 仅当仿真中加载了 H-CPU 的组态时，才

能选择用于打开此对话框的菜单命令。       

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 说明 

错误事件类别 OB73_EV_CLASS BYTE B#16#73（通信冗余丢失）或 B#16#72
（问题已消除）的可能值 

错误代码 OB73_FLT_ID BYTE B#16#E0 的可能值 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。  

   

6.6 时间错误 (OB80) 
通过此对话框可触发会导致调用 OB80 的时间错误。      

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 说明 

超出周期时间 OB80_FLT_ID BYTE 错误代码：B#16#01 

请求的 OB 仍在处理中 OB80_FLT_ID BYTE 错误代码：B#16#02 

当前优先等级的 OB 调用缓冲区溢出 OB80_FLT_ID BYTE 错误代码：B#16#07 

日时钟中断过期：    

* 由于时间跳变 OB80_FLT_ID BYTE 错误代码：B#16#05 

* 在 STOP 后返回到 RUN 时 OB80_FLT_ID BYTE 错误代码：B#16#06 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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6.7 诊断中断 (OB82) 
通过此对话框可触发会调用 OB82 的诊断中断。  

错误条件 

默认测试： （可选）在此下拉框中，通过从列表中选择的方式来设置需要自动测试的错

误条件。 

对于所有故障条件，事件类别 (OB82_EV_CLASS) 都会设置为 B#16#39（进入事件），

OB82_FLT_ID 使用错误代码 B#16#42。如果未选择任何故障条件（模块正常），则事件

类别将设置为 B#16#38（离开事件）。 

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

模块地址 

在 逻辑基址 (页 70)一章中，您可以找到关于不同类型模块的逻辑起始地址信息。 

 

参数 变量 数据类型 

模块地址 OB82_MDL_ADDR Int 

错误条件 

选中相应的复选框来启用以下故障条件： 

 

参数复选框 变量 数据类型 

模块故障（只读） OB82_MDL_DEFECT BOOL 

内部错误 OB82_INT_FAULT BOOL 

外部错误 OB80_EXT_FAULT BOOL 

通道错误 OB82_PNT_INFO BOOL 

缺少外部辅助电源 OB82_EXT_VOLTAGE BOOL 

未插入前面板连接器 OB82_FLD_CONNCTR BOOL 

模块未组态 OB82_NO_CONFIG BOOL 

模块中的参数不正确 OB82_CONFIG_ERR BOOL 

可用的通道信息 OB82_MDL_TYPE BYTE（位 4） 
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参数复选框 变量 数据类型 

可用的用户信息 OB82_MDL_TYPE BYTE（位 5） 

替换的诊断中断 OB82_MDL_TYPE BYTE（位 6） 

用户模块丢失或有错误 OB82_SUB_MDL_FAULT BOOL 

通信问题 OB82_COMM_FAULT BOOL 

工作模式为 STOP OB82_MDL_STOP BOOL 

看门狗定时器已响应 OB82_WTCH_DOG_FLT BOOL 

内部电源故障 OB82_INT_PS_FLT BOOL 

电池已用完 OB82_PRIM_BATT_FLT BOOL 

整个备用电源故障 OB82_BCKUP_BATT_FLT BOOL 

扩展机架故障 OB82_RACK_FLT BOOL 

处理器故障 OB82_PROC_FLT BOOL 

EPROM 故障 OB82_EPROM_FLT BOOL 

RAM 故障 OB82_RAM_FLT BOOL 

ADC/DAC 错误 OB82_ADU_FLT BOOL 

熔断器跳闸 OB82_FUSE_FLT BOOL 

硬件中断丢失 OB82_HW_INTR_FLT BOOL 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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6.8 插入/卸下模块中断 (OB83) 
通过此对话框可触发会调用 OB83 的插入/卸下中断。 

错误条件  

对于所有故障条件，事件类别 (OB83_EV_CLASS) 都将设置为 B#16#39（进入事件）。 
如果未选择任何故障条件（模块正常），则事件类别将设置为 B#16#38（离开事件）。 

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 值/说明 

模块已卸下或未响应 OB83_FLT_ID BYTE B#16#61 

模块已插入： 模块类型正确 OB83_FLT_ID BYTE B#16#61 

模块已插入： 模块类型不正

确 
OB83_FLT_ID BYTE B#16#63 

模块已插入： 无法读取类型 
ID 

OB83_FLT_ID BYTE B#16#64 

模块已插入： 模块参数分配

出错 
OB83_FLT_ID BYTE B#16#65 

模块地址 OB83_MDL_ADDR WORD 在 逻辑基址 (页 70)一章中，您可以找到

关于不同类型模块的逻辑起始地址信

息。 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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6.9 优先级等级错误 (OB85) 
通过此对话框可触发会导致调用 OB85 的程序顺序错误。 如果在操作系统访问某个块时

发生错误（错误代码 B#16#A3），则将自动触发 OB85。      

请注意，事件 B#16#A1、B#16#A2、B#16#B1 和 B#16#B2 必须通过其它方式生成，例

如从程序中删除其中一个所需块。 

可编程参数 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 值 

集成的功能： OB85_Z1 WORD  

无错解决方案 

未加载块 

范围长度错误 

写保护错误 

  W#16#0100 

W#16#0101 

W#16#0102 

W#16#0103 

IEC 定时器： OB85_Z1 WORD  

无错解决方案 

未加载块 

范围长度错误 

写保护错误 

  W#16#0200 

W#16#0201 

W#16#0202 

W#16#0203 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 S7-
300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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6.10 机架故障 (OB86) 
通过此对话框可触发会导致调用 OB86 的机架故障。         

错误条件 

对于所有故障条件，事件类别 (OB86_EV_CLASS) 都将设置为 B#16#39（进入事件）。 
如果未选择任何故障条件（机架恢复、机架恢复但有差异、DP 站恢复和 DP 站点正

常），则事件类别将设置为 B#16#38（离开事件）。 

该对话框的两个选项卡提供以下选项： 

● 扩展机架故障选项卡 

● DP 故障选项卡 

扩展机架故障选项卡 

调用 OB 时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 值 

IM 地址 OB86_MDL_ADDR WORD 连接扩展机架的接口模块的地址。 

故障 OB86_FLT_ID BYTE B#16#C1 

恢复 OB86_FLT_ID BYTE B#16#C1 

恢复但有差异 OB86_FLT_ID BYTE B#16#C2 

扩展机架可再次工作，但

模块参数分配存在错误 
OB86_FLT_ID BYTE B#16#C6 

机架状态 OB86_RACKS_FLT
D 

ARRAY OF 
BOOL 

最多可显示二十一个与接口模块 
(IM) 连接的扩展机架的状态。 在阵

列中，必须选择存在故障条件的机

架。 

绿色 = 良好 

红色 = 故障 

灰色 = 未组态 
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DP 故障选项卡 

通过此选项卡可触发 DP 系统中的故障，并查看 DP 在各种错误条件下的状态。 调用 OB 
时，通过此对话框选择的参数将被传递到以下变量： 

 

参数 变量 数据类型 值 

子网 OB86_MDL_ADDR WORD DP 主站系统的逻辑基址。 

DP 主站系统的故障 OB86_FLT_ID BYTE B#16#C3 

站故障 OB86_FLT_ID BYTE B#16#C4 

站恢复 OB86_FLT_ID BYTE B#16#C4 

所有站恢复 OB86_FLT_ID BYTE B#16#C4 
对所有故障 DP 从站触发“站恢

复”。 不会发出任何消息。 

站可再次工作但存在错误 OB86_FLT_ID BYTE B#16#C7 

站恢复但有差异 OB86_FLT_ID BYTE B#16#C8 

DP 状态 OB86_RACKS_FLTD ARRAY OF 
BOOL 

最多显示 126 个 DP 站的状态。 
在阵列中，必须选择存在故障条

件的机架。 

绿色 = 良好 

红色 = 故障 

灰色 = 未组态 

有关详细信息，请参见 STEP 7 帮助中有关组织块帮助系统的部分，或参见《用于 
S7-300/400 系统和标准函数的 SIMATIC 系统软件》手册。  
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参考信息 7
7.1 图标和菜单命令 

S7-PLCSIM 菜单命令 

 

图标 工具栏 菜单命令 说明 

  仿真  
 标准 文件 > 新建 PLC (File > New PLC) 生成一个具有处于原始状态的新 CPU 的新

实例。 
 标准 文件 > 打开 PLC (File > Open PLC) 关闭当前仿真，并在同一实例中根据已保存

的数据生成一个新 CPU。 

  文件 > 关闭 PLC (File > Close PLC) 关闭当前仿真，并在同一实例中生成一个处

于原始状态的新 CPU。 
 标准 文件 > 保存 PLC (File > Save PLC) 保存当前仿真。 

  文件 > PLC 另存为 (File > Save 
PLC As) 

以新名称保存当前仿真。 

  文件 > 打开布局 (File > Open 
Layout)  

打开已保存的布局。 

  文件 > 关闭布局 (File > Close 
Layout) 

关闭当前布局。 

  文件 > 保存布局 (File > Save 
Layout)  

将当前排列保存为布局。 

  文件 > 布局另存为 (File > Save 
Layout As) 

以新名称保存当前布局。 

  文件 > 最近仿真 (File > Recent 
Simulation) 

打开最近的仿真。 

  文件 > 最近布局 (File > Recent 
Layout) 

打开最近的布局。 

  文件 > 退出 (File > Exit) 关闭应用程序的所有窗口并退出应用程序。
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图标 工具栏 菜单命令 说明 

  编辑  

  编辑 > 撤消 (Edit > Undo) 撤消上一次动作。 
 标准 编辑 > 剪切 (Edit > Cut) 删除所选对象并将其保存到剪贴板上。 
 标准 编辑 > 复制 (Edit > Copy) 复制所选对象并将其保存到剪贴板上。 
 标准 编辑 > 粘贴 (Edit > Paste) 将剪贴板的内容插入到光标位置。 

  视图  
 插入对象 视图 > 累加器 (View > 

Accumulators) 
显示累加器 1 到 4 和状态字。 

 插入对象 视图 > 块寄存器 (View > Block 
Registers)  

显示地址寄存器和数据块寄存器。 

 插入对象 视图 > 堆栈 (View > Stacks) 显示 MCR 堆栈和嵌套堆栈。 

  视图 > 工具栏 (View > Toolbars)  显示特定的工具栏（开/关）。 

  视图 > 状态栏 (View > Status Bar) 显示状态栏（开/关）。 
 标准 视图 > 始终前置 (View > Always On 

Top) 
始终在最前面显示仿真。 

  插入  
 插入对象 插入 > 输入变量 (Insert > Input 

Variable) 
显示输入变量。 

 插入对象 插入 > 输出变量 (Insert > Output 
Variable) 

显示输出变量。 

 插入对象 插入 > 位存储器 (Insert > Bit 
Memory) 

显示位存储器。 

 插入对象 插入 > 定时器 (Insert > Timer) 显示定时器。 
 插入对象 插入 > 计数器 (Insert > Counter) 显示计数器。 

 插入对象 插入 > 通用 (Insert > Generic) 显示数值画面。 
 插入对象 插入 > 垂直位 (Insert > Vertical Bits) 显示字节。 

  目标系统  

  PLC > 上电 (PLC > Power On) 打开 PLC。 

  PLC > 断电 (PLC > Power Off) 关闭 PLC。 

  PLC > 清除/复位 (PLC > 
Clear/Reset) 

删除控制程序和变量存储器。 
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图标 工具栏 菜单命令 说明 

  执行  

  执行 > 钥匙开关位置 (Execute > 
Key Switch Position) 

将 CPU 的钥匙开关置于所选模式。 

  执行 > 启动开关位置 (Execute > 
Startup Switch Position) 

设置启动开关位置。 

 
 

CPU 模式 执行 > 扫描模式 (Execute > Scan 
Mode) 

设置模式。 

 CPU 模式 执行 > 下一扫描 (Execute > Next 
Scan) 

运行下一扫描。 

 CPU 模式 执行 > 暂停 (Execute > Pause) 立即暂停程序。 

  执行 > 自动定时器 (Execute > 
Automatic Timers) 

将所有定时器都设置为自动模式。 

  执行 > 手动定时器 (Execute > 
Manual Timers) 

将所有定时器都设置为手动模式。 

 CPU 模式 执行 > 复位定时器 (Execute > 
Reset Timers) 

复位一个或所有定时器。 

  执行 > 触发错误 OB (Execute > 
Trigger Error OB)  

触发错误 OB。 

  执行 > 扫描周期监视 (Execute > 
Scan Cycle Monitoring) 

用于设置和激活扫描周期监视时间。 

  工具  
 录制/ 

回放文件 
工具 > 录制/回放 (Tools > 
Record/Playback)  

录制或回放一系列事件。 

 标准 工具 > 选项 > 附加符号 (Tools > 
Options > Attach Symbols) 

搜索已下载程序的符号表。 

  工具 > 选项 > 显示符号 (Tools > 
Options > Show Symbols) 

显示变量的符号。 

  工具 > 选项 > 引用数据 (Tools > 
Options > Reference Data)  

显示当前程序当前引用的数据。 

  工具 > 选项 > 符号表 (Tools > 
Options > Symbol Table) 

打开当前符号表。 
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图标 工具栏 菜单命令 说明 

  窗口  
 标准 窗口 > 层叠 (Window > Cascade) 排列所有已打开的窗口使它们层叠显示。 
 标准 窗口 > 按顺序平铺 (Window > Tile 

Ordered) 
按照逻辑顺序排列所有打开的窗口。 

  窗口 > 排列图标 (Window > Arrange 
Icons) 

沿窗口的底部边缘排列图标。 

  窗口 > 1、2、3 ... 9 (Window > 
1,2,3 ... 9) 

激活已打开的视图对象。 

  帮助  

  帮助 > 目录 (Help > Contents) 显示帮助主题的索引。 

  帮助 > 简介 (Help > Introduction) 介绍此应用程序的功能范围。 

  帮助 > 入门指南 (Help > Getting 
Started) 

介绍使用此应用程序的必要步骤。 

  帮助 > 使用帮助 (Help > Using 
Help) 

显示有关使用帮助的信息。 

  帮助 > 关于 (Help > About) 显示此应用程序当前版本的相关信息。 
 标准  在按钮、菜单和对话框上显示帮助。 
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7.2 S7-PLCSIM 数值数据格式 

支持的数值数据格式                      

请参见下表以了解 S7-PLCSIM 支持的数值数据格式。 

 

数值数据格式 大小 示例 

位 位、字节  = 关闭，  = 打开 

二进制 字节、字 1001_0011 

十进制 字节、字、双字 232 

Hex（十六进制） 字节、字、双字 9A 

S7 格式 字节、字、双字 dw#16#9a2ff23 

整型 字、双字 632, –2370 

BCD（二进制编码的十进制） 字、双字 400 

实型 双字 1.234567e+023 

Char（字符） 字节、字、双字 “C”、“AB” 

字符串 254 个字母数字字符 这是一个字符串 

DT (DATE_AND_TIME) 8 个字节 2006-12-25-08:01:01 

注： DT 数值数据格式不支持毫秒。 

如果所有 8 个字节均为 0，则默认 DT 显
示为： 1999-11-30-00:00:00. 

S5TIME WORD 3m5s00ms 

日期 WORD 1998-06-18 

定时器 双字 9h26m53s703ms 

TOD 双字 9:26:53.702 

滚动条： Dec 字节、字、双字 
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数值数据格式 大小 示例 

滚动条： Int 字、双字 

 

滚动条： 实型 双字 
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7.3 故障排除提示 

问题及推荐的更正措施  

下表介绍了一些在使用 S7-PLCSIM 时可能遇到的问题。 也列出了问题的可能原因及推荐

的更正措施。 

 

问题 可能的原因及更正措施 

验证 CPU 是处于 STOP 模式还是 RUN-P 模式。 如果仿真 CPU 处于 
RUN 模式，则无法下载程序，除非已在 STEP 7 中组态 CiR
（Configuration in RUN，运行中组态）元素。在 RUN 模式下，只有 
CiR 对象可以下载到 S7-PLCSIM 中。 

如果程序包含系统数据块 (SDB, System Data Block)，请验证 CPU 是否

处于 STOP 模式。 对于真正 CPU，仅当 CPU 处于 STOP 模式时才能

下载 SDB。 

注： 如果 CPU 视图对象处于 RUN-P 模式，则 STEP 7 会提示您切换到 
STOP 模式，以便可下载硬件配置。 

程序无法下载到仿真 CPU 中。 

验证 CPU 和程序是否使用相同的节点地址和子网名称。 为程序定义的

节点地址必须与 CPU 的节点地址相匹配。 

S7-PLCSIM 应用程序不响应且

显示“已锁定”。 
检查执行模式。 仿真在暂停或处于单次扫描模式时可能会显示为已锁

定。 

您输入一个外设变量但收到“地
址无效”错误，尽管该地址值有

效。 

- 或 - 

您在程序中收到外设访问错误，

尽管 S7-300 项目包含了正确的

组态。 

只有 CPU 315-2DP、CPU 316-2DP 和 CPU 318-2 会下载 I/O 组态。 
如果从其它 S7-300 CPU 下载程序，则系统数据将不包含 I/O 组态。 当
尝试在 S7-PLCSIM 中访问外设 I/O 时，这会导致出错。 

要避免这些错误，首先应在系统数据中创建一个包含已组态 I/O 模块的

硬件配置。 这样，您可以定义哪些 CPU 模块可用。 要执行此操作，请

创建一个项目，然后组态 S7-300 CPU（其中未自动组态 I/O），例如 
CPU 315-2DP、CPU 316-2DP 或 CPU 318-2。将此硬件配置下载到 
S7-PLCSIM 中。 然后您可以下载任意 S7 程序中的程序块。 应用这些 
I/O 时不会出现错误。 

扫描因周期性中断而超期 仿真系统时，必须确保各个周期性中断 OB 的启动事件之间有足够的时

间用于处理周期性中断。 可能有必要相应地延长周期性中断的时间间

隔。 
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Ｂ 

BCD（二进制编码的十进制）数值格式, 87 

Ｃ 

C（计数器）, 16 
Char（字符）, 87 
CiR 元素, 60 
CPU 317-T，仿真, 57 
CPU 工作模式, 60 
CPU 冗余错误 (OB72), 73 
CPU 指示灯, 61 
CPU 累加器, 62 

Ｄ 

DATE_AND_TIME，数值数据格式, 87 
DC 指示灯, 61 
DP 指示灯, 61 
DP 故障选项卡, 80 
DT (DATE_AND_TIME)，数值数据格式, 87 

Ｆ 

F 系统外设 I/O, 59, 64, 65 

Ｉ 

I（输入）, 16 
I/O（输入/输出） 

I/O 冗余错误 (OB70), 72 
与, 12 

输入变量, 64 
输出变量, 65 

Ｌ 

LED 指示灯, 61 

Ｍ 

M（位存储器）, 16 
MC 命令, 57 
MCR（主控制继电器）, 63 

Ｏ 

OB, 69 
CPU 冗余错误 (OB72), 73 
I/O 冗余错误 (OB70), 72 
优先级等级错误 (OB85)T, 79 
机架故障 (OB86), 80 
时间错误 (OB80), 75 
诊断中断 (OB82), 76 
通信冗余错误 (OB73)T, 75 
插入/卸下模块中断 (OB73), 78 
硬件中断 (OB40 - OB47)T, 71 

OB40 到 OB47, 71 
OB70, 72 
OB72, 73 
OB73, 75 
OB80, 75 
OB82, 76 
OB83, 78 
OB85, 79 
OB86, 80 



索引 
  

 S7-PLCSIM V5.4 
92 操作手册, 07/2011, A5E03432190-03 

Ｐ 

PI（外设输入）, 16 
PLC 仿真中的故障排除, 89 

记录/回放, 50 
常规, 89 

PQ（外设输出）, 16 
ProSim, 7 

Ｑ 

Q（输出）, 16 

Ｒ 

RUN, 60 
LED 指示灯, 61 

RUN-P, 60 

Ｓ 

S5TIME，数值数据格式, 87 
S7 格式，数值数据格式, 87 
S7-PLCSIM 锁定, 89 
S7ProSim, 7 
SF 指示灯, 61 
STOP, 60 

LED 指示灯, 61 
与, 12 

Ｔ 

T（定时器）, 16 

二划 

二进制，数值格式, 87 
十六进制 (Hex)，数值数据格式, 87 

十进制，数值数据格式, 87 

三划 

下一扫描，执行, 39 
下载到 CPU 

问题, 89 
工作模式, 60 
与, 12 

四划 

中断 OB, 12, 69 
OB40 - OB47（硬件中断）T, 71 
OB82（诊断中断）, 76 
OB83（插入/卸下中断）, 78 

为仿真 CPU 接通以及断开电源, 48 
为仿真附加符号, 49 
冗余错误 

CPU (OB72), 73 
I/O (OB70), 72 
通信 (OB73)T, 75 

手动定时器，使用, 48 
日期，数值数据格式, 87 
计数器 

查看和修改, 67 

五划 

主控制继电器 (MCR), 63 
外设存储器, 16 

与, 12 
访问错误, 89 
垂直位, 68 
输入变量, 64 
输出变量, 65 

打开 
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事件文件, 50 
打开连接消息, 89 
打印按钮，帮助窗口, 31 
电话号码，支持, 7 
目录选项卡，帮助窗口, 31 
目标系统 

仿真, 41 
记录/回放, 50 
记录/回放状态, 50 

六划 

仿真 CPU 317-T, 57 
仿真 PLC 

监视, 41 
优先级等级错误 (OB85), 79 
关闭 

带连接的仿真, 89 
创建新事件文件, 50 
后退按钮，帮助窗口, 31 
回放, 50 
回放事件文件, 50 
在线帮助, 31 

F1 访问, 31 
帮助窗口中的按钮, 31 

地址寄存器, 62 
多实例 

下载 STEP 7 项目, 25 
仿真, 25 
保存, 25 
选择连接类型, 26 
通信, 27 

字符串, 87 
字符串，数值数据格式, 87 
存储区, 16 

I/O, 12 
与, 12 

过程, 12 
安全状态未更改, 12 
扩展机架故障选项卡, 80 
扫描模式选项, 39 
机架故障 (OB86), 80 
过程映像, 16 

与, 12 
垂直位, 68 
输入变量, 64 
输出变量, 65 

七划 

位，数值数据格式, 87 
位存储器, 16 

查看和修改, 66 
块寄存器，查看和修改, 62 
技术支持, 7 
时间，数值数据格式, 87 
时间错误 (OB80), 75 
状态字, 62 
诊断中断 (OB82), 76 
诊断缓冲区，与, 12 
运动控制仿真, 57 

八划 
使用 

记录/回放, 50 
使用 S7-PLCSIM 监视仿真程序, 41 
使用 S7-PLCSIM 调试程序, 44 
视图对象, 59 
帮助, 31 
符号寻址, 49 
滚动条控件, 42 

使用 S7-PLCSIM 调试, 44 
单次扫描程序执行 
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在调试时使用, 44 
单次扫描模式 

设置, 39 
垂直位，查看和修改, 68 
定时器, 16 

与, 12 
手动, 48 
复位, 48 
查看和修改, 66 

实型，数值数据格式, 87 
视图对象, 59 

ACCU 和状态字, 62 
CPU, 60 
F 系统变量指示, 59 
计数器, 67 
位存储器, 66 
块寄存器, 62 
使用, 41 
垂直位, 68 
定时器, 66 
通用变量, 67 
堆栈, 63 
滚动条, 42 
输入变量, 64 
输出变量, 65 

九划 
保存 

布局, 36 
事件文件, 50 

八划 

变量表, 12 

九划 

复位定时器, 48, 66 
客户支持, 7 
帮助, 31 

F1 访问, 31 
帮助窗口中的按钮, 31 

持续扫描模式 
在调试时使用, 44 
设置, 39 

故障排除提示, 89 
显示和附加符号, 49 
显示按钮，帮助窗口, 31 
相关手册, 7 
相关文档, 7 
选择 

扫描模式选项, 39 
最大滚动条值, 42 
最小滚动条值, 42 
数值数据格式, 42 

选项按钮，帮助窗口, 31 

十划 

格式，数值数据, 87 
监视 

仿真程序, 41 
真正 S7 PLC 与 S7-PLCSIM 的区别, 12 
站故障, 80 
索引选项卡，帮助窗口, 31 
通用变量，查看和修改, 67 
通信冗余错误 (OB73), 75 
高亮显示搜索字词，在线帮助, 31 

十一划 

停止记录/回放, 50 
控制程序，监视, 41 
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符号寻址, 49 
符号的工具提示, 49 
符号表, 49 
累加器，类似于 S7-400 CPU, 12 
累加器和状态字，查看, 62 
隐藏按钮，帮助窗口, 31 

十二划 

嵌套堆栈, 63 
插入/卸下模块中断 (OB83), 78 
插入模块中断 (OB83), 78 
搜索在线帮助, 31 
暂停记录或回放, 50 
最大滚动条值, 42 
最小滚动条值, 42 
硬件中断 (OB40 - OB47)T, 71 
程序仿真, 41 

十三划 

数值数据格式, 87 
数值数据格式，滚动条控件, 42 
数据块, 16 
数据格式, 87 
滚动条，数值数据格式, 87 
输入, 16 
输入变量 

变量，查看和修改, 64 
输出, 16 
输出变量 

查看和修改, 65 
错误 OB, 69 

OB70（I/O 冗余错误）, 72 
OB72（CPU 冗余错误）, 73 
OB73（通信冗余错误）, 75 
OB80（时间错误）, 75 

OB85（优先级等级错误）, 79 
OB86（机架故障）, 80 

十四划 

模式，扫描, 39 

十五划 

增量按钮，记录/回放, 50 

十六划 

整型，数值数据格式, 87 
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