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The order numbers for MMC cards are in the following table:

Micro Memory Card / S7-300 Order number

64 Kbytes 6ES7 953-8LF11-0AA0
128 Kbytes 6ES7 953-8LG11-0AA0
512 Kbytes 6ES7 953-8LJ11-0AA0
2 Mbytes 6ES7 953-8LL11-0AA0
4 Mbytes 6ES7 953—-8LM11-0AA0
8 Mbytes 6ES7 953-8LP11-0AA0
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QUESTION 2 : MMC R _EAFREFE PR EREAR R I PR M) AT 4 2

Is there any restriction to the number of blocks I can load onto an MMC (Micro
Memory Card)?

ANSWER:
Yes, there is a limited number of blocks you can load onto an MMC depending its
size as shown by the table below:

|Type ‘MLFB |Maximum number of blocks
MMC 64KB 6ES7953-8LF11-0AA0 | 768
MMC 128KB 6ES7953-8LG11-0AA0 | 1024
MMC 512KB 6ES7953-8LJ11-0AA0 | 2560
MC 2MB 6ES7953-8LL11-0AA0 | 6528
MMC 4MB 6ES7953-8LM11-0AAO | 12672

Table 1: Maximum number of blocks on an MMC



Please note here the applicable quantity framework for each CPU (number of blocks
altogether).

& [

QUESTION 3 : 4nqafffilfx MMC & L HSREEE 7 ?

How can I delete the data or program on a MMC (Micro Memory Card)?

You can use the following procedure to delete the block on an MMC in the CPU:

—_

The MMC to be deleted is slotted in the CPU.

2. In the SIMATIC Manager, switch to online mode via “View > Online” or by
pressing the appropriate button.

3. In the Online window, you select the block folder.

4. Select all the blocks in the folder which you want to delete

5. Click the "Delete” key on your PC keyboard (you can acknowledge the

message that system functions cannot be deleted).

QUESTION 4 : 31X & PLC #& A\ MMC E)5, STOP {T AMENIER, B4H? B sk MMC?
Why does the STOP LED flash on my CPU 31xC when the MMC (Micro Memory Card) is
slotted? The CPU does not behave like this with other MMCs

ANSWER:

The MMC in your CPU is not formatted or contains data that cannot be interpreted by
this CPU (e.g. the configuration of a different CPU type or an operating system not
compatible with the CPU).

WARNING:
When you format the MMC all the data that is located on the MMC is deleted!

Proceed as follows to format the MMC.

1. Your CPU requests an overall reset (slow flashing of the STOP LED).

2. Put the switch into the MRES position and hold it there until the STOP LED
lights permanently (approx. 9 seconds).

3. You must then release the switch within the next 3 seconds and then put it
back into the MRES position. The STOP-LED now flashes during formatting

If the MMC cannot be formatted as described above, then the MMC is defective



NOTE:

It is only possible to format the MMC if there is data located on the MMC that is
invalid for the CPU. Otherwise the MMC is only initialized through the steps
described.

More information on the MMC is available in Entry ID: 8861901

1B [H

QUESTION 5 :3HA MMC K S7300 PLC ANERIE® i Fl SFC54 FRFFHR?
Why does the SFC 54 “RD_DPARM” not work with the new S7-300 CPU with MMC?

ANSWER:
In the new S7-300 CPUs with micro Memory Card, SFC 54 “RD DPRARM” for reading out

a data record of a chosen block of the system data configured with STEP 7 has been
replaced by SFC 102 “RD DPARA”.

SFC 102 ”“RD_DPARA”, in contrast to the old SFC 54 ”“RD DPARM” is an asynchronously
executed system function. This means that the processing is extended over various
SFC calls.

Blocks containing SFC 54 ”“RD DPARM” can not be loaded to a new S7-300 CPU with MMC.
Therefore, please replace the call fo the SFC 54 “RD DPARM” by the call of the SFC
102 “RD_DPARA” and adjust your programming logic to the asynchronous behaviour of
the SFC 102 “RD _DPARA” an.

Below, you will find a comparison of the two system functions:

SFC 54 “RD DPARM” SFC 102 ”“RD DPARA” Observations
Inputs

Function will be executed only with

N REQ REQ:lY new for SFC 102

Parameter has been dropped for SFC 102;

101D o see LADDR

SFC 54: any block address, specification
of the E resp. A address range over I0ID
((B#16#54=Peripherie Eingang; B#16#55=
peripherial output) SFC 102: any block
address; Specification of the E resp. A
address range over bit 15 of LADDR (most
siginficant bit) Bitl5=0 —> peripherial
input Bit15=1 => peripherial output

RECNUM RECNUM use identically
Output

LADDR LADDR

use identically; however, there are
RET VAL RET VAL additional error numbers for SFC 102 at
disposition.



BUSY=1; the order has not been finished

- BUSY so far, there are no results at
disposition
RECORD RECORD use identically

Table 1: Comparison SFC 54 and SFC 102

& [

QUESTION 6 : 3¥F MMC £ S7300 A1 C7613, 635 ZF| CPU BT 52 SREIE R FFTHRE M) 2
How does the remanence function of the S7-300 CPUs and C7-613 and C7-635 compact
devices work with Micro Memory Card?

ANSWER:

The remanence characteristics described below affect the S7-300 compact CPUs, S7-
300 modular CPUs and the C7-613 and C7-635 compact devices with MMC. We describe
the remanence characteristics after changes in operating mode in terms of data
blocks, times, counters and markers

Data blocks:
e CPU STOP/RUN or Power OFF/ON

1. Database contents of CPUs 31xC, 312, 314, 315-2DP, C7-613 and
C7-635 are always remanent.

2. The DBs can be defined as remanent or non-remanent for the
CPU 317-2DP.
Therefore, a setting in STEP 7 (V5.2 +SP1) 1is required for
CPU317—2DP:
O An explanation for the activation or deactivation of
the option “Non-Retain” in the block properties of the
DB, can be found in the entry—ID: 17146856 or
0 a DB was created with SFC 82 “CREA-DBL”. While
creating a DB with SFC 82 it is determined in the
attributes of the DB in Bit 2, whether the DB shall
get remanent or not

Note:
Only 256K bytes of the main memory (512 Kbyte) can be used
for remanent data blocks at a CPU 317-2DP! No remanent DB


http://www4.ad.siemens.de/-snm-0135038936-1077799491-0000004994-0000000003-1078286015-enm-WW/llisapi.dll/17146856?func=cslib.csinfo&objId=17146856&objAction=csView&lang=en&siteid=csius&aktprim=0�

will be created anymore and the value 80B2 (not sufficient
main memory) will be displayed, if the main memory is too
small for remanent data blocks

e Memory reset (MRES)

1. The data will be reset to the values in the loading memory
(initial value). These are the last current values which were
loaded with the PG into the CPU or which were written with
the SFC84 into the loading memory.

2. All blocks of the loading memory remain unchanged. The data
blocks are initialized in the main memory.

e CPU Power OFF -> pull MMC —> Power ON -> Power OFF —> plug MMC —> Power ON

1. The data are reset to the values in the loading memory. These
are the last current values which were loaded from the PG
into the CPU or written into the loading memory with SFC84.

2. All blocks of the loading memory remain unchanged. The data
blocks are initialized in the main memory.

Note:

If it is required to safeguard current data, those have to be saved
on the MMC (loading memory). SFC84 can be used for this purpose. The
frequency of the write accesses on the loading memory is critical
because a MMC only allows 100,000 write accesses

Markers, times and counter:
These operand areas can be defined as remanent or non—remanent in the HW
configuration under “Object properties CPU > remanence”

e (CPU STOP/RUN or Power OFF/ON
These operand areas keep their values if they were defined remanent
Otherwise they lose the values and will be initialized with 70"

e Memory reset (MRES)
These operand areas are deleted during the memory reset, regardless whether
they were defined remanent or non—remanent

e CPU Power OFF —> Remove MMC —> Power ON —> Power OFF —> Insert MMC -> Power
ON
If they were defined as remanent, these operand areas retain their values
Otherwise they lose their values and initialize with “0”. This
characteristic applies if the same unchanged MMC is inserted again.

QUESTION:
What does “Non—Retain” mean in the Properties — Data Block dialog?

ANSWER:

In STEP 7 version V5.2 + SP1 and higher you have the option of selecting the
property “Non-Retain” in “Properties — Data Block” in the “General — Part 2” tab.
You can define the remanence behavior of data blocks with this option.



Properties - Data Block X

General - Part 1 General - Part 2 |Ealls | Attributes

Marne [Header]: I Yersion [Header): IU.'I
FEannily: I Author: I
— Lengths
Local Data:
Data: 0 bytes
Load kMemaomny Requirement: 80 bytes
Whork b emary B equirement: 36 bytes
[T DB is write-protected in the PLE [~ Standard block,
I~ Enow-how protection [~ Unlinked
Wi ri

Cancel Help

Fig. 1: Properties — Data Block

The requirement for this option is that the CPU supports the Retain property of
data blocks.

A data block with the property “Non—Retain” is not stored in the remanence memory
in a CPU 317 -2DP and is thus reset to the original load values at each power
OFF/ON or each STOP-RUN transition of the CPU.

A data block with the “Non—Retain” property occupies RAM space as usual, but no
remanence memory space

Note:
The CPU 317-2DP has a RAM of 512 KB, but only 256 KB of data can be retained

& [

QUESTION 7 : UMK — RGO E AT B A< B U B MMC 1?2

Can I also save other files that belong to the project or system on the MC/MMC?

ANSWER:
You can save any file connected with the system on the MC/MMC.
Procedure:

e Slot the memory card or micro memory card into the PG.



e Open the SIMATIC-Manager.
e Go to “File > S7-Memory Card > Open”.
e Then go to "PLC > Save to Memory Card ...”~.

JSIMnTIE Manager - ST memory card

File Edit Insert | pLC  Yiew Options ‘Window Help

Ol g? = Access Rights r £ MaFi
B it

(]
ESd 5 & MEMmOtiy, Compile Snd Download Gbjects ;

----- £ STmeman | pjaad
Upload Station

Copy BAM Eo RO,
Download user pragram Ea memarsy) card

Manage M7 System. ..

Display Accessible Nodes

CPL Messages. ..
Displat Force Yalues
Manitar Todify. Yariables

DiagnosticfSetting 3
PROFIBUS 3
Assign Ethernet Address. ..

Assign PiE/PE

Cance| PEPE assianment
Update Operating Systen. ..

Fig. 1: SIMATIC Manager — S7 memory card

e In the left file explorer you select the required file and mark it for
saving with the “—>” button.



HSIMHTIE Manager - 57 memory card

File Edit Insert PLC Yiew Options window Help

| 23|em| & [E=le) ol o 2= 2oft-

EST memory card

[[< No Fiter > 17| =@

Save files to Memory Card

—STEP 7 Data

Projects/Libraries... |

— Other files

Search in: I[EJ MTEF j

DM TBFwapdate_11 21z

updats_11

I oK. | Cancel | Help | I

e If you want to remove files again from the selection, use the "<—” button.
. Click “0K” to save the selected data to the memory card or micro
memory card.

e You receive an acknowledgment once the data has been saved.

e Then the data transferred is displayed in the ”S7 Memory Card” window.

HEIMHTIE Manager - 57 memory card

File Edit Insert PLC ‘Wiew Options ‘Window Help
D3| 28 2|52 sl [ 2 ) B

----- {£H 57 memany card update_11.xlz

Fig. 3: View of data in memory card window

Note:

You can only use this function for an S7-300 Micro Memory Card and S7-400 Flash
EPROM card.

AN il



QUESTION 8 : FRAHKGIRM STEPT I H 5o BHRAFAE MMC R |, Z%E#FEZ K MMC?
How can I determine the size of the MMC so that I can store my complete STEP 7
project on it?

ANSWER:

In order to choose the appropriate MMC for your project you need to know the
overall size of the project and the size of the blocks to be loaded. You can
determine the size of the project as described below:

First archive your STEP 7 project. Then open the archived project in Windows
Explorer and determine its size (select and right-click). This gives you the size
of the archived file

test.zip Propetties E 2l x|

General |Securit}l| Summary

E Itest.zip

Type of file:  Winip-Datei

Openg with; @ Wirgip Executable LChange. . |

Location: H:AFaQ-Daten

Size: 393 KB [403.340 bytes)

Size on digk: 296 KB [405.504 bytez) |

Created: Freitag, 13, Dezember 2002, 13:18:0
Modified: Freitag, 13, Dezember 2002, 13.15:08
Arncessed: Freitag, 13. Dezember 2002, 13:18:31

Aftributes: v Archive

Cancel Sppy

Fig. 1: File properties

Load your blocks into the CPU. Now you still have to select “PLC > Module
Information > Memory”. There, in “Load memory RAM + EPROM”, you can see the size of
the assigned load memory.



ﬁIMndule Information - CPU 315-2 DP ONLINE 101 x|

Path: |.-’-‘u:c:essible ModeshtdPl = 2 [directly] Operating mode of the CPU: @ R
Statuz 0K Mot a force job
Time Syztem I Performance Data I Communication I Stacks
General I Diagnostic Buffer i ; Scan Cycle Time

Agzignment;
[sizes in bytes) 4% 9%
Load memary BAM + EPROM Wwhiork Memor}l|
Free: 118.800
B iscigned: 12272
Total: 131.072

Largest Free Block:
tdaw. Pluggable:

LCompress | Detailz Memorn Area... |
Cloze I Update | Frint... Help |

Fig. 2: Load memory

You must add this value to the size of the archived project you have already
determined. This gives you the overall amount of memory required to store your
complete project on an MMC.
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QUESTION 9 : Xl AMMCE HIST300PLCHEAT TIN%, EREC T HEH, WHTA BEXtMMCHE
2, BRBERMICE L ih23mg?

2. R IR T EAEST-300CPU Protection/@ftd T ik & 2508, R4 Hiems R H
siemensHI4mFE#EPG (6EST798-0BA00—-0XA0) | fr)i A ul % I 7 USB4E LI i3 £ 8 (USB
prommer 6ES7792-0AA00-0XA0) , IEFESIMATIC Manager Fitifl FHIZEE File>ST7 Memory
Card>delete JETMFRMMCE EIRA M NZ, XFEMCHL AT UME A — D RINEW = -REH T, H
TEIERIMMCR TR,  SEHOMMCR H (72 7 sl 28
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