技术论坛

第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。

作者 主题
游民

经验值: 123
发帖数: 62
精华帖: 2
第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 16:54:14
发现的第一个问题:CP5611无法与CPU通讯;

两天之后得出:原因为,IM360,361无法正常工作(有电压显示,但全报警,SF灯红);

第五天了,单机架调试,4-20mA的信号都到了前连接器了,STEP仍然没有办法读到数据,一直显示16#0000007FFF,想哭。。。

有没有人告诉我这是为什么呀?帮帮忙阿。。555。。。

小妹这厢有礼了。。。



简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
重要声明:

著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

帖子链接:https://www.ad.siemens.com.cn/club/bbs/post.aspx?a_id=350837&b_id=4

游侠

经验值: 455
发帖数: 431
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 17:07:41
CP5611无法与CPU通讯和IM360,361没关系吧。
检查接线
有空聊聊
以下网友喜欢您的帖子:

  
游士

经验值: 174
发帖数: 135
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 17:25:56
多看说明书,西门子的帮助文件还是不错的!
 
以下网友喜欢您的帖子:

  
游民

经验值: 145
发帖数: 81
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 18:37:12
无法读取外部数据可能与你没有配置好模块有关系,你应该首先在step7中将模块逐块设置好。
然后你再试试就应该可以了的。
 
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。在线等斑竹和各位高手 !!


只看楼主 2007-07-05 19:13:07
360,361无法正常工作,属于硬件故障,所以,CPU的SF也一直亮着,报警。

PG/PC信号测试的时候,指出:硬件OK,但是有与PROFIBUS有关的同步错误,原因就是CPU无法正常工作,我以为。

各位大哥认为,有其他原因没有?到底360,361为什么无法正常工作呢?

单机架联机测试的时候呢,所有的模块在“硬件诊断”中都能被找到,并且OK。数字量信号也可以显示和给定。

但是,现在我弄不明白的就是,明明在前连接器处,各信号通道已经检测到有24V,并且有5.2mA、5.48mA,20.1mA的电流信号了,STEP 7 却依然固我,不管有没有信号输入的通道,全都显示“16#000007FFF”。

从现场仪表到仪表盘有显示的,仪表盘到PLC柜的信号也全部确认了,没有接线错误,正负极性亦没错。。


究竟怎么回事啊,百思不得其解。。。。
简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 19:22:45
我的说明书也全看了。。

有个这样说明:
无论参数设置如何,所有的模拟量输入模块都将返回测量值7FFFH,做为对出错的反应。此测量值指示上溢、出错或禁用的通道。

软件也做过检测了,由于在读PIWxxx地址输入信息时,读入的就是:32767,所以,其输出就总是超出了传感器本身的量程范围,而,SM331模块在线监测的时候,就总是显示“16#000007FFF”。

怎么电流信号明明都已经传到了前连接器,模块却无法检测得到呢,真是奇怪,难道前连接器和模块之间没有发生联系,但是也不应该每个模块都出现这样的情况啊。。。

模块有24V电压的。。。

简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
游士

经验值: 224
发帖数: 171
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 20:59:16
兄弟,你检查一下接地。
太难了。
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 21:29:36
偶不是兄弟啊,偶是MM。。。

刚才有高手跟我说,可能是串220进来之后,361通过连接电缆368把220串到上一个机架的361和360了,所以,把所有的模块都烧了。。

可是,偶只会检测信号通道是否被烧,不会检测模块的呢,各位大哥,可有办法检测?

小女子这厢流泪求助。。。
简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
游士

经验值: 224
发帖数: 171
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 21:41:01
那你一个一个模块单独检查吧。可能会花点时间。
太难了。
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 21:48:20
检测模块被烧用什么办法,偶不会啊?
求指教...
简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
版主

经验值: 55000
发帖数: 16431
精华帖: 315
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-05 23:00:37
模拟量模块的量程块跳线是否设置正确?
Zane 注册自动化系统工程师 Always save before download
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 00:47:53
模块量程如果设错的话呢,应该SM331会报警的吧,我调试的时候,试过了2线制4-20mA和4线制的。量程设错了,SF灯亮,CP5611与CPU无法通讯的。

总结下目前排除的原因,包括我的疑问,请指正:

1。接线
(测试过在前连接器处,有电流信号,并且与现场仪表盘的是一样的,信号的正负极性都是对的。)

2。量程(如上)

3。通道
(把模块拆下来测试了每一个通道,通道的各个管脚都是通的,并且电路板上分配给每个传感器的25欧电阻也OK。)

4。模块烧坏
(如果模块被烧坏了,就不应该在模块的L+和M端检测到24VDC了吧,各个通道也应该无法正常工作吧?)

5。360和361都被烧坏了吗?
如果接口模块的361和361之间能通过连接电缆368传输220的信号,接上360之后,360的SF就报警,CPU无法通讯。同样的情况也适应于361。。

6。CPU被烧坏了吗?
如果CPU被烧毁了,即使是单排机架也无法正常通讯的吧?
CPU本身会因为系统硬件或软件的故障报警而无法与CP5611通讯。

7。背板总线烧了?背板总线也能传220V的信号?
背板总线一般只有5VDC的,有个220过来肯定死翘翘了,但是,背板总线传的都是数字信号了吧?难道数字信号也带220V的/?

如果背板总线烧了,那我在线监测的时候,怎么还可以看到各个模块的硬件诊断信息呢?


8。还有一个,如果数字信号模块,321,322被烧坏了?
如果321被烧了,模块还能正常显示现场传过来的信号吗?或者状态灯能给假信号?

如果322被烧了,为什么我还能在线给信号给它,并且状态灯有相信的变化,还能听到继电器动作的声音。

8。但是如果,所有模块都没有被烧坏。

为什么CPU接上360,361就报警,无法与CP5611通讯呢 ?

为什么在331的前连接器检测到信号,却无法显示出来,永远显示16#00007fff或32767呢?


到目前为止,实在是没有哪位的回答能够说服我的,有没有高手能指点一二?


小女子跪求解答!!
简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
奇侠

经验值: 6872
发帖数: 5350
精华帖: 25
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 02:34:28
感觉你的PLC只是比较欠缺 建议你还是找一个有经验的同事学习学习吧 否则跟你说一些检测方法恐怕也是无济于事
怎么论坛改成这样了??
以下网友喜欢您的帖子:

  
侠圣

经验值: 3870
发帖数: 577
精华帖: 18
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 09:34:57
只把CPU放上试,没问题再加321,322。CPU再单独带一个331,331模块的量程块,信号输入方式都要设置正确后试一下。反正就是一个一个试吧
业精于勤,行成于思
以下网友喜欢您的帖子:

  
游民

经验值: 123
发帖数: 62
精华帖: 2
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 09:51:49
嗯。。我的PLC知识确实比较欠缺呢,如果什么都通晓的话,恐怕不会有这么多疑问了。
最不幸的是,目前我一个人在新疆的戈壁滩上,根本没有同事可以请教,所以拜托大家,告诉我一个检测的方法。。


现在,我先按照“火麒麟”师兄的方法测试。

希望有好消息噢。。

简单地活着,快乐地生活,幸福地守候我的四月天……
以下网友喜欢您的帖子:

  
侠士

经验值: 1204
发帖数: 846
精华帖: 19
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 10:13:00
先将所有模块拔出,只留下CPU、电源,清除所有程序,BF灯是否还亮?如果BF灯熄灭,CP5611连接M区的地址,测试一下是否可以完成,在完成后,依次断电后插入模块再上电检测,看查到那个模块会引起红灯,这样可以简找到故障的模块,通常就是接线不正确、模块跳线错误等引起,如都正常,下载配置,如出现BF亮,则是配置错误。检测完以上均正常,下载程序,出错的话基本就是程序问题了。
虽然繁琐,但分步检测是PLC最基本的调试手段。
naga xel:有时笨办法可以解决聪明问题,所幸俺总有笨办法。
以下网友喜欢您的帖子:

  
游士

经验值: 195
发帖数: 153
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 11:02:35
我建议你按照“火麒麟”师兄的方法试一下,一个一个模块的试。
另外,我觉得其实西门子的技术支持还是不错的,你可以打电话给他们,只在论坛上等也不见得有太大效果,解决问题的渠道不能太单一,是不是啊?
 
以下网友喜欢您的帖子:

  
至圣

经验值: 39957
发帖数: 8431
精华帖: 389
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 11:03:56
会不会是选择的307电源容量太小?或368电缆有问题?另360与361之间最大距离为10M这一规则是否严格遵守?
天生不宜做胜利者,自来没有胜利的欲望,只是不甘失败,十分十分不甘心失败。木心
以下网友喜欢您的帖子:

  
游士

经验值: 195
发帖数: 153
精华帖: 0
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 11:05:28
忘了说他们的电话了8008104288
慢慢来,别着急,总会有解决方法的
 
以下网友喜欢您的帖子:

  
侠士

经验值: 1744
发帖数: 606
精华帖: 1
回复:第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。


只看楼主 2007-07-06 11:18:33
1,你的pc(cp5611)通过mpi还是profibus和plc通讯呢
2,用360-361来扩展模块的,相对比较简单,主要检查接线和插槽,必要更换模块替换来排除
3,模拟超量程,请点击 http://www4.ad.siemens.de/WW/view/en/11966082 阅读在线FAQ。
通常,从SM331的通道中读出7FFF上溢值或8000下溢值的现象可以通过正确的外部接线避免,各种信号及各订货号模板的接线参见本文相关章节。如果在外部接线完全满足模板要求的情况下,仍然出现读数超限,则有可能是信号源接地不好、信号电缆敷设过程中有电磁干扰等原因造成M-与Mana间电势差Ucm过大。这种情况下建议采用有源信号隔离器。另西门子网络上有比较详细关于sm331的资料。

 
以下网友喜欢您的帖子:

  
收起
第一次出差做工程,遇到问题一大箩,哭啊。。。请高人指点。。
×
扫描打开手机版
您收到0封站内信:
×
×
信息提示
很抱歉!您所访问的页面不存在,或网址发生了变化,请稍后再试。