技术论坛

300软冗余时的热插拔问题

作者 主题
HLC
新手

经验值: 32
发帖数: 15
精华帖: 0
300软冗余时的热插拔问题


只看楼主 2009-01-07 15:39:17
300软冗余配置,从站支持热插拔,热插拔ET200M从站上的模块时是否CPU仅仅对热插拔的这个机架失去控制,其它机架则无影响?
 
以下网友喜欢您的帖子:

  
重要声明:

著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

帖子链接:https://www.ad.siemens.com.cn/club/bbs/post.aspx?a_id=517069&b_id=4&s_id=0&num=5

至圣

经验值: 32138
发帖数: 13387
精华帖: 51
回复:300软冗余时的热插拔问题


只看楼主 2009-01-07 15:52:21
错了,对其他的都没有影响只是拔下的这个模块无法控制。其他的还照常通讯,但是你需要加入热插拔的ob块。
活到老,学到老!为了生活学习吧!
以下网友喜欢您的帖子:

  
侠圣

经验值: 3456
发帖数: 1525
精华帖: 18
回复:300软冗余时的热插拔问题


只看楼主 2009-01-07 17:40:55
楼上显然没有真正做过软件冗余,楼主是正确的
与人规矩,不与人巧!
以下网友喜欢您的帖子:

  
版主

经验值: 58150
发帖数: 16806
精华帖: 327
回复:300软冗余时的热插拔问题


只看楼主 2009-01-07 19:17:53
S7-300不支持DP总线热插拔,整个机架会DOWN掉
Zane 注册自动化系统工程师 Always save before download
以下网友喜欢您的帖子:

  
侠圣

经验值: 2631
发帖数: 642
精华帖: 22
回复:300软冗余时的热插拔问题


只看楼主 2009-01-08 08:22:39
300的软冗余并不完全支持热插拔的全部条件,算是“半”热插拔吧。
添加了相应的OB块之后,只是硬件能够实现带电插拔,所在机架报故障,该机架的其它模块也不能正常工作。
没有个性的签名就别签了。
以下网友喜欢您的帖子:

  
侠圣

经验值: 2032
发帖数: 981
精华帖: 5
回复:300软冗余时的热插拔问题


只看楼主 2009-04-16 14:43:16
ET200M需要使用有源底板

1.带电插拔模块时,确保不造成模块的硬件损坏;
2.带电插拔模块时,CPU 不停机,并产生报警;
3.带电插拔模块时,该模块I/O 通道的数值保持不变,而其他模块的运行不受影响;
4.带电插拔模块时,CPU 中触发中断组织块或通过DP 诊断程序块,得到模块拔出或插入的事件信
息,在用户程序或中断组织块OB**中进行相应控制逻辑和I/O 通道的处理;

采用S7-300 作为主站的软冗余系统无法实现热插拔全部功能,不具备以上所列第3,4条目中的功能。当您将ET200M 从站上的模块拔出时,CPU 不停机,主CPU、备用CPU 上的SF 灯亮,BUSF 灯闪烁,ET200M 从站上的2 块IM153-2 模块的SF 灯亮,BF 灯闪烁,该ET200M 从站上所有模块的I/O 值被清0,S7-300 主站失去对该ET200M 从站的控制能力。当您再次将模块插入到ET200M 站上时,系统从主CPU 切换到备用CPU,SF、BUSF、BF 灯熄灭,软冗余系统重新回到正常运行状态。
 
以下网友喜欢您的帖子:

  
  • 上一页
  • 1
  • 下一页
收起
300软冗余时的热插拔问题
×
扫描打开手机版
您收到0封站内信:
×
×
信息提示
很抱歉!您所访问的页面不存在,或网址发生了变化,请稍后再试。