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Q BOOL Retentive output
| 05 BOOL For the memory function (switch on)
MW 4 INT Actual speed for diesel engine

| 16 BOOL Diesel engine failure
Q 56 BOOL Command for switching on diesel engine fan
T

2 TIMER  Follow-on time for diesel engine fan :[X E ’T/ S U\ ﬁ‘ EIJ &8 Ge‘t‘“ng
5.4 BOOL Command for switching on diesel engine
G 5.5 BOOL Display "Diesel engine preset speed reached’| »»

DB 2 FB 1 Datafor diesel engine Started 74]—\‘12]— EP IE/FU ﬁu%% E"J 87
FBE. 1 FB 1 Engine control
DE 10 FB 10 |Instance data block for FE10 1 /v 11
FB 10 FB 10 Example of multiple instances *Ir? E‘]?‘ﬂ‘%‘?%
FC 1 FC 1 Fancontrol

Q 40 BOOL  Result of AND query I 4 =
| 0.1 BOOL For the AND quevyr T 1/ w Jﬁ j‘% ﬂlg $F|] ﬁ *E IEI =
| 02 BOOL For the AND

| 03 BOOL Forthe OR qj:rgyyy /I\ S7 %Ir? B — A5
| 04 BOOL For the OR query
OB 1 OB 1 This block contains the user program i%

| 06 BOOL For the memory function (switch off) o

MW 2 INT Actual speed for petrol engine S sope e =
|12, [BooL  Panl sngia e PeAT W AT BV IR 545 (- e R 7
T

Q

Q

Command for switching on petrol engine fan

50 BOOL —Commans or swiehing or el angins P, SSKR)EET LLAE 2 i A

25 |PE_On
26 |PE_Preset_Speed_Reache 5.1 BOOL Display "Petrol engine preset speed reached”
27 |Petrol DB 1 FB 1 Data for petrol engine
28 |Red_Light Q 4.1 BOOL Result of OR guery
29 |S_Data DB 3 DB 3 Shared data block
30 |Switch_Off DE | 15 BOOL Switch off diesel engine
| 31 |Switch_Off_PE I 1.1 BOOL Switch off petrol engine
| 32 |Switch_On_DE | 14 BOOL Switch on diesel engine
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Failure

ZIIRER “Petrol” I ASH#R Bas ik,

¥ R IBAE “ Switch_on” J& il (11455 13
AR ATHE

PR bR A B B S R Insert
Crsetsymbal D ol | Symbol. B AN FRAIE, BRE K
PE, X R B LB ]

Actual Speed
Engine On :
Preset_ Speed Reached:




QI MT D RES AR SRRy

PE_O Q& - v N
PE_Prr:aset_Speed.“ 0 5.‘ ){—Z—'\EE‘ Switch_on_PE, 12*’\% ?M?Tﬁﬂ
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o WREA RS TS, XK FERG M. RAT DU B mr e AT
AT DU N T8 G i P B o
o WMRREA LR —E W PRI R TR, RE R R R
CPU Rt “Stop” i, MRATLLFEIEANFE/FH] CPU, Mk G ix i i o
& RIE
ESERR 2, IR H R, PRATRETE BB O FAREl CPU [, BLX A4k, AEAELLE N
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I 0.1 "Key 1" BOOL
I 0.2 "Key 2" EOOL
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Incoming event
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Address (Decl. Hame Type Initial ValiComment
0.0fin Engine_On BOOL Signal for switching on the engine
2.0[in Timer Function |TIMER Timer function used for the switch-off delay
4.0|out Fan_oOn BOOL Signal for switching on the fan
in out
temp

FKE RSB 48 T2 E FT 25 Th &E

S NI N A SE ]

Timers /7\ o

VR eomr R R S
F| S_OFFDT CJi B4 I 157 IF
D, TR

22.2 E s_o?r;; ; 22,2 Eﬁ)\ S Zﬁﬁ?ﬂia)\g/l\f%%ﬁ
%? Em fii i, AR Z AR AN

LR BCD|-... @ ()_o
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Gife IIfE

TR SN R AR AN A2 T (#F5 S AR,
£ S_OFFDT AN TV L 'E BB A], SBT#4S J&—AN e SOh B 2 7Y
SETime#(SETH I L, FFLkia 4 72 (4S),

XA DRAFIZ I RETF ORI 1
#Timer Function
#Engine On S OFFDT #Fan_On
| 5 Q {}) I
S5T#HAS TV BI—...
R BCDf-... “ #Time_Function” Hi i1 \ Z %

“#Engine_On" i3, “i%IIfe
7t OB1 iz G, et 7
R RN Sk, Sk
PGPS —xk CFlan, T1
“PE_Follow_on"”). #R¥7E LG
RS RN IX LS T 5
e

84



Gife IIfE

FiE R RmIZER 2RTIAE

| WK VB R g FE, BB T 4K
fempan 5, HPRRN

#Timer Function . R o
#Timer_Function 5:1?51%@12%?%3?9% IZT-J PI%T M.

#Fan_On

I w B
=]

FAThRELR Bl 4m72 E BT RITH BE -

U R AR I S RE B G R, I FEBC T IR DI, O g I 2 S BE Fas A\ T (1
FBD F/¥.

e RAFIZIIRETF ORI B 1

#Timer_Function

S_OFFDT
#Engine_On—3 BIf...

S5TH#AS — TV BCD|-. .. #Fan_On

AR E I 5 DHBEAS BIALBE, AREEAEFIN) 73 A5 B i — it R b A i Dl . (AEFRATTIY
Bl EAE OB D,

7t Help>Contents 8 “if =%

7, “STL. FBD ak LAD i &= ik ” #1 5
#4547 T ARSI BT 2 065 6
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Gife IIfE

8.3 7£ OB1 HiARINRE

XDt FCT IR AT 5 X S 7E OB X D RESR I FIARML, 7
OB1 I e sh AL s S i e s LA AH . ) M Bk 25 DI RE R BT S 48
AL -

HI TR LB IR RAERT 538 S0 BUERR R INIX S bk (0455 44
Motk STEP 7 A&7y, EAREMBLE N ASATHR S . Hh
BEWT DA A I AT 1

B, | @ () = o | SIMATIC Manager %[5 H “Getting Started”

= mm i) System Data 081 FE1 ol
3D e @m o= BRAREEIH — [F4T IF .
$£3 Blocks S Jf4TJF OB1, LAD/STL/FBD
GuLEd 1147 T

R AR CAE R WY o AR H (GS-
LAD_Example,GS-STL_Example, 8% GS-
FBD_Example) 1 HIFF 5K EIRM “Getting
Started” T H, ARG IAEFTFT S T o
ELUREMES
HI3E ¥4 Options>Symbol Table M LAD/STL/FBD 4ifiti (4T IFF 5%, ff
M DA LR S 4 TR BN B 5 RIEH
WAEHE R AR S MBI 53K

Symbol | Address |Data Type| Comment
DE_Follow_On T 2 TIMER Follow-on time for diesel engine fan
PE_Foallow_On T 1 TIMER Follow-on time for petral engine fan
Fan FC 1 FC 1 Fan control
PE_Fan_On Q 5.2 BOOL Command for switching on petrol engine fan
DE_Fan_On Q 5.6 BOOL Command for switching on diesel engine fan




Gife IIfE

Rt RZEmE AR

PRAE LAD BLE . FlA— DB (BN
BO. RJEAEGFECE Hok b A E 23R
FFC1, A IZIIRE.

7E “Engine_On" Z Hi4fi A —~# TFfil

o ran_onl- 27,7 131 = ¥ iy 4 ViewsDisplay>Symbolic
R — Representation 1] LAYERF 5 il A 4ot
Hudik 2 )4 o
sy FC MRS, AR5 4.
EN rran” ENO
"PE_On" Fan_On|-"PE_Fan_On"

|l j
|| Engine_On

"PE Follow On" —{Timer Function

FES LB g DRE FCT [ I FAE A Sl & sh Ll it ik o
JHFST B IRCZK S ARSI L I BIRF 5 24 o

"Ean®
EN ENO

"DE_On" Fan_On—"pE_Fan On"
I} Engine_On

"DE Follow On" —Timer Function

ﬂ| AP IR XA

Woh = dr 4 ViewsDisplay>Symbol Information
SBREEABrh A R E R

AR DE W BB oOR LA B, B K B &
View>Dispaly>Comment.

i FI =% ¥fir 4 View>Zoom Factor, i] LEiAR & (R B
RN o
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Gife IIfE

&AMz A

Hetwork 6 : Controlling the Fan for the Petrol Engine

CALL "Fan"
Engine_On :="PE_On"
Tiwer_ Function:="PE_Follow On"
Fan_On :="PE_Fan_On"

Hetwork 7: Controlling the Fan for the Diesel Engine

CALL "Fan"
Engine On :="DE_Cn"
Timer Function:="DE Follow On"
Fan_On :="DE_Fan_oOn'"

FAThRERE 4RAZ IE -

R R GiRE, A HTE
R TR A X, NI LR
(1) STL #EH].

SRR APAL NPTl R

WAL ShRe s R, AE— NPT BN NEF A X O R FBD

%o

RJE AL R PR B

"Fan"
... —EN
"PE_On" —Engine On Fan_On—"pE_Fan_On"
"PE_Follow On" — Timer_ Function ENOf—
Fan
...—EN
"DE_On" —Engine_On Fan_On="DE_Fan_On"
"DE_Follow On" —{Timer Function ENOf—

FEBATH R Fram eI DI RERTHALZ — N4 B, iZIIRER BB
WRIGARK) B SNAAEF I EER, AT DRI LA AR Zh R s zh e B B, — M A sk
— AT BB SE R . HER PN EN BT ENO U2 H TP 14 A .

8-8

7t Help>Contents 38 “if = %%
By”, “LAD. FBD m% STLiE S ik ”, ok “F2
FPEdlER 4 ] LUK BB 2 (115 R
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9.1

mIE— T HZLER

BIZEFITH

W

HZHHER

Wk CPU BT AL WS (K A BSAF A AL R AR AE T AT i, DR 2895
(R A7 i 21— IR B

FEREAESE R PP B AT AL e R DR . T4
SRR E g MEE I DIREDR, B IEE RAEIXAS DI REH N )
AR 5.5 #Y).

RIS C 2 A T HIBRTEIZ 8 . Dlfig P I B FU 2 2 R (0L 55 DY 2 A0
ST DLRAT S i RO 26 = 5E) o

open IR SUNSRIT R T R et} SIS

I THEATIH “Getting Started”, i

TEFT I E .

WREA, K Har4 File> “New

Project ” Wizard 7E SIMATIC
Manager A —ASHIHIH . 2

£Dt01_05_STEP.. LA 2.0 b e S I E

ZDt01_06_STEP...

d0 1 0 @A ZIH N ¢ Getting Started
Function”,

BAVK 4k a4 ] “ Getting Started”
TH o AR — AN H e BLSE
W

JEA7 2 Blocks SCHFIIFFT 2. H R
FrAT B s T AT

+ Projects

[3etting Started
ZDH01_02_STEP..
ZDt01_03_STEF..
Z0H01_04_STEP..
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Gfe AR

9-2

New Data Block

MBS G A —) Data Block(DB).

7F “Properties-Data Block” X i A
F OK 252 i g W E .

T — D M5 B “Help” #4 .
¥tk DB3 S In A\ 2| Blocks 33
o

X747 JF DB3

EBE J5 L “New Data Block” Xt
TEAE FP G 1615 Data block (B ER) .
HI OK SCPATXf 1EAE .

[BliZ: 1E 5.5 FJrh Rad i Bas
&I “Data block referencing a
function block(Z% — /N Ihfig
PRI ER) 7 AR B — AN 1 S A
. 52 M, H “Datablock”
ARV AN I S e




e AR

feio

ERIRR P RET

7E Name(% )R i N

# “PE_Actual_Speed”.

sl AR A B PR AL, A S
Bt ) 3§ 4w 4 Elementary
Types>INT.

NG, DB3 g T =N, AR A WA P X LR

AN o

PE_Actual Speed INT 0 Actual speed for petrol engine
DE_Actual Speed INT o] Actual speed for diesel engine
Preset Speed Reached |BOOL FALSE Both engines have reached the preset speed

XFTEHE Bt T SE bR E BE I AR R
“PE_Actual_Speed” Fil “DE_Actual_
Speed” IHIAbEE 5 7T MW2(PE_
Actual_Speed) fl MW4(DE_Actual_Speed)
A XA N —F T HH

. (AP A Sk,



Gfe AR

DEFS

PRt AT AZEH A R e — T 5 44
FJF Symbol Table(F55 %)k ¥k He

DB3 i \7F 5 4 “S_Data”.

L RS SR DY B FEAR T H
(zEn01_02_STEP 7_STL_1-10,
zEn01_06_STEP 7_LAD_1-10 =,
zEn01_04_STEP 7_FBD_1-10)"1#2 D147
SHRFMRE “Getting Started” i H,
IAEARAS TG EESE IATAT AT =

Symbol ' Address |Data Type| Comment

S Data DB 3 DB 3 Shared data block

El {RAEFF 5 £ I M) “Symbol Editor(£F
SYREEAR)” .

G P e B AR B S R

L EFRRPHHZHIRIR:

i H 4 View>Data View ] 3L 8l BB R rp a7 INT [ SEPsfEL(L 5.5
oY)

fFSRPIHLZHER:

L SHRYUA R, AR5 R I B R SR K R 2R A SR e ik . AEBRATT 7R B,
Hne Mzt “DB3”. TR S EdaT, AN D) RS SR i I B 2R

7t Help>Contents T3 “gufeth” 1 “ Gl dsh”
CIVE S FEA Gl =S
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10 HE—ITZTEER

10.1 fIEFITARS —RBITHRELR

ERFRRAIE T — AR, HIIEEHR “Engine” (FB1)#H]—4
KHPL. HIhREER FB1 (B2 OB1 iRy, i T #dks bk

“Petrol”

(DB1)#1 “Diesel” (DB2). HEANEdi Bt & K SNHIAS A (1) s (51 4,

#Preset_Speed). BAERG—T, R AR &E T EHL BT
BEHIRANL: B, — AT SRR SRR, sk
ML, % I HTTR OSSP, IAEIREE — AN & 3)
BUFEHIRE A FB, I HoRax AN R BRIk 5 73 le — A8
e Flan, FB1 A DB3 H Tk & s, FB1 Al DB4 H]
TERENHL, FE, OREIEUE R RSN IR, P A 1
T2 AH 2w .

Fy—J7 M, AR 2 FAY SO AT DAk D B R . X AE, (R
B — N, Bom— I D Re B (FEFRAT T s il P FB10), JF7E
Fo i AR IE S0 FBY AR —A “ R 5¢7. W aE— A,
TR FB1 R e B A A4 FB10 H%idis tk DB10 e X
BRI FB1 Sy BAAT g, Fr A (0 D e Pedlida 1 — A4
P (X B & DB10),

¥4tk DB1 A DB2 #5E%4E DB10 H, #iX
2NE, DAIRAE FB10 [ER JRidh A FB1.

oB1 FB1O .
CALL FB10, DB10 OALL Bt b7 Ll bl
CALL FB1 (3 4t 5 3h7#1)

:> = "Engine"
% d DB10
- - % “Petrol Engine” %
“Diesel Engine” %t
FB1
"Engine" ); D
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Gife D EIH

PRIV IZ S AR T HEREZ . DAY alh A1) R g fe (LR VYR ER 1055) DL AT 5
Y (LA — %)

- = WAMREAER — R CET I EHT
@& )’\ “Getting Started” /=pl, /7F “Getting

(-*I Projects Started” Wi [,

WREAT, wI{E SIMATIC Manager H14T
FFELF I 22—

ZDi01_02_STEP...

ZDt01_04_STEP..
ZDt01_05_STEP..
ZDt01_06_STEP..

S

zEn01_02_STEP 7_STL_1-9 H TiEA)#
zEn01_04_STEP 7_FBD_19 I T-IhfEb A,

[
C
C
Zown 03 STEP.. € zEnO1_06_STEP 7_LAD_1-9 H THi/EiB4H,
C
C
C

AR Blocks LI IFFT I E -

PR AT B i AT 1, T S P4
A A Tfed.

KA 80k FB10 IRk 60T i 1 g R i

General - Pat 1 IEar-d Pait2| Attibutes | N
e g Y=

smmm
zz:v;,m IW #id Multiple instance FB(I S A W EE)
Date created: ::;;ssmmn it ) )EH OK %U\E%E@ﬁfé\&ﬁo
Conmet | 5 FB10 #in A\ %] Blocks 3t . XHFTIT
[ FB10.
e

PRAT IR R D RES QR 2 AT, flan, NI TEHIRR R . WR IR ZAE ] 2 S 5,
VT PSRN Y DR 20 2 B SN g

7f Help>Contents 3@ “gufetl” F1 “4)

YU ] LRSI B 22 145 S
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Gife DT ETH

10.2 %% FB10

0% FB1 /EH FB10 fl—A “ Wil 15 St (local instance)” i8R, W55 4G —A FB1
FIR AN AFA A PSR, X, BRSHE FB1( “Engine” )

HETERMRAR
LAD/STL/FBD #ifE & HATIF. 4 FB1 AT AW LL N A &t
Address [Decl. Hame Type Initial ValiComment
in
0.0|out Preset_Speed Reached BOOL FALSE Both engines have reached the preset speed
in_out
2.0|stat Petrol Engine "Engine" First local instance of FB1l "Engine"”
10.0(stat Diesel Engine "Engine" Second local instance of FB1 "Engine"
0.0|temp PE_Preset_Speed Reached [BOOL Preset speed reached (petrol engine)
0.1|temp DE_Preset_Speed Reached |BOOL Preset speed reached (diesel engine)

AT R I SOR IR A e 3R H 3%
] “Multiple Instance (£ B 15 5) N«

#6212 45472 FB10

% Bl AN A
“Petrol_Engine” 1k % H ¥
Sl “Petrol_Engine”,

R NPT PR T A s O A5 2 58 i

#Petrol Engine
EN ENO

"Switch On PE"

Engine Cnf-"pE On'"
| | Switch On

Preset_Speed Reac| §PE Preset Speed R
"Suitch Off_PE" hed —eached B
| | Switech OFf
"PE_Failure" ﬁﬁ]*ﬂﬂg “ACtuaI_Speed 7 AR
| | Failure HAFHAL(N, 5.6 FIMER), TRk
"S Data".PE_Actual B ICEH (L 9.1 #4p). &
~Speed Tetue fpeed JH O S ok W Kk R W F
“ Data_Block ” Addres, i 1 :
“S_Data” . PE_Actual_Speed.
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Gife 2

EIEN=N
H

10-4

TN ADFBOF S SN . 2RSS 1 BUR 7307 .

Preset_Speed Reac

#Diesel Engine
EN
"Switch_On DE"
|} Switch On
"Switch Off DE" hed
|} Switch Off
"DE_Failure"
I { Failure
"S_Data".DE_Actual
_Speed —Actual_ Speed

ENO
Engine_On —"DE On"

#DE_Preset_Speed R
—eached

TN —ASFBOF AN R b i B — > HR IR L o SRS DRAF AR IR

BSIENCIl 3

#PE Preset Speed R #DE Preset Speed R #Preset Speed Reac

eached eached hed

| | | | {1} |
1T VS 1

FRi&ER14TZ FB10

CALL #Petrol Engine

Switch_On :="gwitch On FPE"

Switch Off :="Switch Off PE"

Failure :="PE_Failure"

Actual Speed :="3_Data".PE_Actual Speed
Engine_On :="PE_Cmn"

Preset Speed Reached:=#PE Preset Speed Reached

CALL #Dlesel_Engine

Switch On :="Switch On DE"
Switch Off i="Zwitch Off DE"
Failure :="DE_Failure"

Actual Speed :="3_Data".DE_Actual Speed
Engine On :="DE_On"
Preset Speed Reached:=#DE Preset Speed Reached

#PE_Preset_Speed Reached
#DE_Preset_Speed Reached
#Preset_Speed Reached

e

IR AS & ( “PE_Preset_speed_
Reached” I “DE_ Preset_Speed
_Reached ” ) #t #& it 45 %1 tH = %4

“Preset_Speed _Reached”, &¥
7E OB1 it — P AbE .

W SRARAE I )RR, AE BT
S NTprEE AN T P AN o 3
/R STL F5 4

IR DRAFAR IR P I R A Z




Gife DT ETH

FIThERE 477 FB10

WK Zh e iR, 72— BB MIESRMAXEIH A IR FBD 4.
IR DRAF AR B RE PP I 5% P B

#Petrol Engine

.. —EN

"Switch On PE" —Switch_On

"Switch Off PE" — Switch Off Engine_Onf="pg on"
"PE Failure" —Failure Preset_Speed Reac| #PE Preset Speed R
hed Feached

"3 _Data".PE_Actual
Speed —actual Speed ENO [

#Diesel_Engine
.. —EN

"Switch_On DE" —Switch On

"Switch Off DE" —{Switch Off Engine Onf="pE on"
"DE Failure" —Failure Preset_Speed Reac| #DE Preset Speed R
hed Feached
"3_Data".DE_Actual
Speed —Actual Speed ENO =
&

#PE_Preset Speed R

eached — #Preset_Speed Reac

hed

#DE_Preset_SpEEd_R =
eached —

LAE FB10 rhgmiExt FB1 BRI, FB10 AL A2t
ZHEB SRR D) RERgw Tl A DIRE(FO) I 2 1T SO AT REN.
7t Help>Contents R 8 “4ufEh”, “Aldi2H

o, BRI IR TR
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Gife D EIH

10.3 4 DB 10 FiAELPRE

PSS DB10 B KRS DB1 1 DB2. JH TV & shHLAISEm &SP %L
WA AE DB10 W, JTHi#E OB1 il FB1 P2 A BN 5.6 #4041 )5 11 “OB1
T FB17 ).
FIS 13248 SIMATIC Manager 1, 75
T H “Getting Started” ] Blocks 313
A s DB10.

BEX AR, AE BRSO B
ff144°7 2 DB10, JJ OK A AR i i .

T — 05 DB10 LA, ATTFIRIR A
Block: DB10 “New Data Block” dialog box.

Progiamming took  [DB Edior ¥
ot ¥ % ¥ 7 Data block referencing a
£ .Dda ——— function block(Z % —> T e i Ko dhs k)
« Data block referencing a function block N

— JiiH FBI0,

W T OK HiA i =,

Hiitk DB10 BT IEFEH P ir

View>Data View,

< Data VieE >
Declaration View

B Ef Bon DB10 g —
AR, 4 FB1 MIPIKIE
R Rt 5t ).
el R R e s R N S
i1 FB10 1 A B ) — 4% o
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Gife DT ETH

S RSB SER ISR “1300%, AERK B S0

Address |Decl. Hame Type Initial Value |Actual Value [Comment
0.0|out Preset Speed Reached  BOOL FALSE FALSE Both engines have reached
2.0|stat:in Petrol Engine.Switch On BOOL FALSE FALSE Switch on engine
2.1|stat:in Petrol Engine.Switch Off  BOOL FALSE FALSE Switch off engine
2.2|stat:in Petrol Engine.Failure BOOL FALSE FALSE Engine failure, causes the|
4.0[stat:in  [Petrol Engine.Actual Speed INT 0 0 Actual engine speed
6.0[stat:out Petrol Engine.Engine_On BOOL FALSE FALSE Engine is switched on
6.1[stat:out Petrol Engine.Preset_Speed Reached [BOOL FALSE FALSE Preset speed reached
3.0[stat Petrol Engine.Preset_Speed INT 1500 1500 Requested engine speed
10.0|stat:in Diesel Engine.Switch On  BOOL FALSE FALSE Switch on engine
10.1|stat:in Diesel Engine.Switch Off  BOOL FALSE FALSE Switch off engine
10.2|stat:in Diesel Engine.Failure  BOOL FALSE FALSE Engine failure, causes thel
12.0|stat:in  |Diesel Engine.Actual Speed INT 0 0 Actual engine speed
14.0|stat:out Diesel Engine.Engine On BOOL FALSE FALSE Engine is switched on
14.1|stat:out [Diesel Engine.Preset_Speed Reached |BOOL FALSE - Preset speed reached
16.0|stat Diesel Engine.Preset Speed INT 1500 c - quested engine speed

#iax)e

MAEFTE MR EEASAE DB10 MAREFRF . Er-—F, R LIE 28 Dhagbh
“Petrol_Engine” MAL &, J&—Fr & HThfitdh “Diesel_Engine” (28 & (W, 5.5

FB1 [ “WEB” ZRRANRFEFEAINGG S 4; B, “Switch_On”. BLE RS 4 T
DU INAE I L5 44 (W TR 0, “Petrol_Engine.Switch_On”,

7t Help>Contents ¥ “Zmfidie” F1 “f

EHEPL” H R AR R 2 45 R
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Gife D EIH

10.4 7£ OB1 i FB 10

EIRAT R G, 76 OB1 difif] FB10. XM SR 4 27t i1
OB1 #xf FB1 i A MR L RE(W. 5.6 FB0 41 )5) . (2 &
5o, RO LU 5.6 #0 H dn iF B 4 R B

FIIFIH T OB, ARNICEIZIH 4w

=7 Started - C:ASIEMENS\STEP7AS Zproi\Getin_1 a
=2 Getting Stated
] imnr,;msmn [ﬁ i+ f it N
= [@ cruzig) _J. FB O
B & 7 Pogentl) System Data 081 81 FB10 bo ’I o
() Source Fies
S i E i

TR O A 56 DY 75 AR AR5 H

ol e (zEn0O1_02_STEP7_STL_1-10,
zEn01_06_STEP7_LAD_1-10 g,
zEn01_04_STEP7_FBD_1-10)/4£ 1 T
5 RARN “Getting Started” i H,
ENHELR IR R AN 5 BB AR 455 T

LAD/STL/FBD Zw#2 % H4TJF. FZEH4r4 Options>Symbol Table #JF4F
S, NIhAEH: FB10 AL DB10 A/ SR TPMART 54 . RIGIRIERT
FRIFKMZE .

Symbol | Address |Data Type| Comment
Engines FE 10 FB 10 Example of multiple instances
Engine_Data DE 10 FB 10 Instance data block for FB10 10
F#E 22 48 w72 1

1E OB1 [R45 AR N — N F BT vt
aaine FB10( “Engines” I .

Enaines
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Gife DT ETH

RBNMFHFS AR THAEM.

MR OB1 Xt FB1 MIHAICR B 5.6 #i2> 0B 4 FBL B), DI IRATHLE
i FB10 ki FB1.

RAFREF I R AZ B
"Engine Data"
"Engines"
EN ENO
Preset_Speed Reac| "3 Data".Preset Sp
hed eed Reached
FB10( “Engines” )i {5 5
“ Preset_Speed_Reached ” 4
PRI R D A
RiEm&RmZ AR

WERARAE AR g, 75— B B NGB A X I N R i) STL
B4 Tk, (FHgECE HH i FB BLocks>FB10 Engines.

MIER OB1 o FB1 i I(5.6 #BorHIBL 4 MBL 5), PN IATIAE R FB10
P FB1.

SR G DRAFRR P I G

CALL "Engines" , "Engine Data”
Preset Speed Reached:="3 Data".Preset Speed Reached
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Gife D EIH

FRThaERE 4RIz A

WARARAE I ShREH g fs, 7 —ASBTB P B N X SO R FBD 84
BUX 2 gw e e E H 3 1) “FB Blocks>FB10 Engines.

MIBE OB1 Hixf FB1 KU (5.6 #4314 FEL 5), KATRATIAEE S FB10 K
W FB1,

SRIGORATRR T I G T

"Engine Data”

"Engines"
Preset_Speed Reac| "3 Data".Preset Sp
.. —EN hed —eed Reached
. ENO f—

AR B ST S TR B & M REDLESRA T Bl v Rabl. A RahhLes
55, G VMR RV 7 A T 0 2 RS BT FBAO I AT, B A 1, % FBI0
A P e R OIS RETS WAL FO R B AL FB10 sh4REst FBY A (S e e
a2 B 5. S5, ARATLUE SURTIIZE 5 4 Wll, 76755 %rh hHEl(Switch_on)
FW TF(Switch_off) ik 5 X445

7t Help>Contents FH & “HHZ%HY)”,
“STL. FBD 5k LAD &5k ” Al “Refrfailia £
TRl AR 2 145 B
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11.1 F PROFIBUS DP 759 # =t I/0

HA WA B M RG] i BERE AL RS R T &, XL
LA R P R R R AR /O B L. KT R A R
k.

AT A, R A N B R AR S 1) 0 A s R T 2 AR
(77, AT AD KE EEk . AR e LA PROFIBUS DP kg7 nf
FEB I AS 1VO BEIBCRIIIAT B & 2 I & Hs: . (EER /ST h R g
BB A A — A A . Bl R4S A AN A X
LA A NI o ARAT LAEERE H 55 b e B AR e AT 22
ELENUEE L, SRR ESRE e T TR .

FEIRIX— T2/, FAFIRE GG T B H A gm e — A b e gl 2 (I
2.1 AN

Rt it A,

BRI NS 45t ET200M-IM183
1/O %A ET200B-16D1/16DO

F i ANk 22T 1)
PROFIBUS-DP 4%

/)

CPU FgwfE % #%/PC 2 [
ik MPI ) B ER.

T Hl:
CPU315-2DP
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HE53 A 1/0

BlE— A ¥R E
T — 106 N SIMATIC Manager. b ffiix—
= FEIAT IR, ST 4T RO

Q- AEIH

EA N IS EHEFE$E CPU 315-2DP(HFE
PROFIBUS-DP ¥ [ CPU).

IAEFE IR 2.0 FB o PR R R T, 4%
5 H 20l — 44 7-“ GS-DP ”(Getting Started
Distributed 1/0).

TR AR X B A R B O ASBRAE T LA
FREMRIK CPU, JERAKM CPU M HEr
iz 1/0.

EXE %FE GS-DP STt A Slbs A7 B il Ao
“laite | vmn T # 14\ PROFIBUS .
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A4 110

¢ SIMATIC 300 Station i3 )Xl
Hardware(fif {4:), “HW Config (& {41
&) @ FTIFOL 6.1 #4))

- CPU315-2DP CLZetHELAENLAN . WA 4
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